5

I've got a pair of headphones with an inline microphone in the cable, connected into a socket that is described in the "other connections" section of the manufacturer's spec list as:

Dual Microphone, Stereo Speakers, DC Jack, 1 Headset (Audio)

It's not the clearest prose ever written but it sounds to me like it's describing a dual socket for microphones and stereo speakers allowing the connection of one headset for audio purposes. So I expected the two to just work together.

My problem is, when I connect my headphones, nothing happens. Nothing appears in the "Recording" section of Control Panel > Sound > Manage Audio Devices, and programs like Skype fail to see it as an input option. The headset does work perfectly first time on other devices e.g. an Android phone.

Do I need to do something like install drivers before this will work? Is detecting headsets something Windows 8 is normally capable of? If not is there any 3rd party software etc?


This is similar to Drivers for headphones with in-line mic and remote control but in my case I am trying to use a dual socket, whereas that answer assumes seperate audio out and mic in input and recommends a splitter cable.


Vinayak asked in the comments about 3rd party audio manager applets. My machine has some Realtek thing, I've never had much success getting anything useful out of such things before and usually go straight to the windows settings but these are the relevant settings I can find. So there's an unticked "analog" button, and a confusingly worded dialog box (open in the screenshot below, reached via Device advanced settings on the right) about tying up or separating inline devices - which sounds like what I'm looking for but for the fact the setting that sounds like the one I want appears to already be selected:

enter image description here

The icons under Recording Volume are Mute and Microphone boost, and there are no options on the drop down for Set Default Device - clicking it does nothing.


I've found this which suggests that up-to-date RealTek should be capable of working with such a thing... and I'm 90% sure that this device (a very new 2015 high-spec pro-tablet) does have a compatible jack socket. But I've got no idea how to debug this. Most pages I find just say "most PCs need a splitter cable", but this machine has no seperate mic jack (unlike its predecessor I believe) and seems to have the correct jack and correct software. :-/


It is possible: After some frustrating trial and error, I did briefly get it working. It involved switching to "Separate...", but when I tried to retrace my steps to make screenshots for an answer here, it completely didn't work, either way this setting is set. I feel like I've redone everything I did that made it work for 5 minutes with no joy, so I don't know what I did that made it work.

It is however now aware that there has been an external mic called Mic in at front panel but it won't recognise it when it's plugged in. For example, Windows has it listed as "Working properly" but "Not plugged in" (it's actually quite the opposite). Before, this only ever had the internal mic listed:

enter image description here

...and Skype remembers I told it to prioritise the external mic, but doesn't realise the exact same external mix is plugged in, and only uses the internal mic in test calls:

enter image description here

2
  • Do you see a control panel applet you could use to configure your sound setup? On my system, I have an app called SmartAudio that lets me change the behavior of the combined audio port to make it work with headsets, headphones or microphones. The configuration screen looks like this.
    – Vinayak
    Jul 20 '15 at 19:54
  • Good question, there is an equivalent, I've added all the details about it to the question but haven't found anything that makes it work yet. Jul 20 '15 at 21:23
1
+50

First, make sure the recording device is actually enabled. Open "Sound" in Control Panel, switch to the Recording tab, right-click in the main white list box, and make sure "Show Disabled Devices" is checked. If it's not, check it, then right-click any new list box entries and choose Enable.

If there were no disabled entries, Realtek's front panel jack detection probably got confused. On the Speakers tab of the Realtek HD Audio Manager, click the folder icon in the upper-right of the jack icons (where it says "Analog"). Check the "Disable front panel jack detection" box in the resulting dialog.

If that doesn't work, you might toggling the option in the dialog box your screenshot depicts. (I don't actually see that option on my system, so I'm not exactly sure what it does.)

2
  • I don't have a folder icon where it says Analog on mine, but I think you may be right about it getting confused. Hadn't occured to me that "jack detection" was something that could get confused... I'll try turning it off and on again (again) Jul 20 '15 at 22:38
  • @user568458 The folder icon appears on the Speakers tab (not Microphone) for some reason, though documentation seems to suggest it can affect microphone input as well.
    – Ben N
    Jul 21 '15 at 14:46
1

Much trial and error later I have it most (but not all) of the time. If anyone can piece together a more coherent explanation, please do post it and I'll accept it. This isn't helped by the fact there are a myriad of different versions and makes of all the software here... for me I think the important steps were:

  1. Telling the audio manager to treat different microphones as different microphones, which in my case was through this (Separate all input jacks):

enter image description here

  1. A wild inline microphone appears, named something like Mic in at front panel (black). This is really temperamental. Sometimes I have to restart the computer after changing the setting to make it recognise that anything is plugged in, sometimes I just have to "Okay" it and go back into the audio manager, sometimes it just works immediately. Uggghhh. As Ben N aludes to, "jack detection" is not something robust that just works, it's something that can fail or get confused.

enter image description here

  1. There should now be options in audio-using applications regarding which microphone to use, for example in Skype there are options in a drop down and the one you select goes to the top of this behind-the-scenes advanced settings priorities list:

enter image description here

2
  • I am 99% certain that the Mic in at front panel (black) won't and can't work for you. Are you absolutely sure that, in your tests, the inline microphone actually worked? Could it be that the built-in microphones have been picking up your test sounds all along and mislead you?
    – misha256
    Jul 20 '15 at 23:50
  • Here's how I tested it: standing 1.5m away from machine wearing headset facing away from machine: 1) with headset plugged in say phrase A, 2) unplug headset, 3) in same position as before say phrase B, same volume. When the Mic in front is not selected in Skype, both are almost inaudible. When it is selected, A is perfectly clear, clearer than using the inbuilt mic from a normal distance, while B is almost inaudible. Jul 21 '15 at 1:02
1

I'm afraid you have misunderstood the specifications. When Wacom say:

Dual Microphone, Stereo Speakers, DC Jack, 1 Headset (Audio)

They're actually specifying four discrete features:

  • Microphone array (comprising of two microphones embedded in the tablet)
  • Stereo speakers (embedded in the tablet)
  • DC power socket
  • Headphone jack

The headphone jack is only a headphone jack. It cannot support microphone input. The specifications and the user guide confirm this. Also, notice the black screen-printed icon beside the jack on the tablet itself - this icon indicates headphone functionality only:

Headphone-only jack

7
  • I believe you're right that I misunderstood the microphone/speakers/DC part, thanks, but it's described as headset jack and as illustrated in my answer and the additions to my question it has worked, but inconsistently - shouldn't this be impossible if you're correct and it's only a headphone jack? Is there some way a headphone jack to inconsistently sometimes work as a headset jack? Jul 20 '15 at 23:45
  • @user568458 Yeah, exactly, the jack should never be able to work as a mic (unless the hardware+driver is able to re-purpose the jack to function as mic, but that would be an 'unspecified feature' and probably unsupported). Still, even in that case, I really do suspect the jack is only wired up to do one thing at a time. On your behalf, I'm actually really annoyed at Wacom. The specifications say headset while the user guide says headphones. Which is it? And, this is hilarious, the user guide also mentions "2 mic jacks". They aren't jacks, they are built in microphones!
    – misha256
    Jul 21 '15 at 0:50
  • @user568458 I'm struggling to find more evidence that could confirm the jack is output-only. Here's something, but it's for the original version: forum.wacom.eu/viewtopic.php?f=12&t=22479. The poster says " found out the jack is only for output, i need an usb adapter".
    – misha256
    Jul 21 '15 at 0:55
  • It's not clear if that last link is about the Companion 1 or 2. This is a companion 2. I think companion 1 had two seperate jacks? Also I've tested it again (see comment replying to your comment on my answer), the inline mic definitely does work when the software has the mic as an option. Jul 21 '15 at 1:04
  • 2
    Yes - I made a recording of me drumming on the headset cable's inline mic while listening to a music video through the headset speakers: playing back, the recording worked. Also, tapping lightly on the cable makes the input meter for the front jack mic go up to 100%, even when 1.5m from the built in mic, so it must be the mic in the cable that is doing it Jul 21 '15 at 8:31
1

Have you tried restarting Skype to see if it reflects the changes this time? (it could be that skype locks the input device it's using on startup so if your mic is unplugged at that time, it might lock onto the onboard mic)

Regarding the Analog Socket:

I have the same icon (black) on the Realtek Controls on my Laptop. Whenever I plug it in, I get a popup with 3 options, 'Headphones', 'Headset', 'Speakers'. With Headset it uses the inline microphone, and for anything else, the onboard microphone. That's what the driver is supposed to do. Set external as default, and switch to it, when it is plugged in.

enter image description here

Since my version of the program doesn't show the advanced settings, it just shows 1 microphone only. Otherwise, separating the inputs often show all the existing input options.

About the specification:

My guess is, with 'Dual Microphones' they meant a couple of internal microphones to enable 'Stereo' recording. My phone (Nokia N8-00) has the same thing in specifications, and a picture showing the location of the second microphone.

2
  • Amazing, three people with RealTek drivers, and they're all completely different... gotta love windows. You seem to have the version with the folder icon that Ben N referred to. Does this popup just appear when you plug anything in? Which is the black icon you refer to - do you mean the strange black circle under "analog"? Jul 24 '15 at 0:19
  • Yes. It pops up as soon as something is plugged in. And also Yes, I think realtek refers to multi-purpose headset sockets as analog and colours them black. But this is my first encounter with a black socket icon(Other than the one used for 7.1 channel rear speaker out on desktops), so I wouldn't really know for sure.
    – RiA
    Jul 24 '15 at 0:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.