0

UPDATE:
I know this has been marked as a duplicate, but none of the following duplicate answers have worked (including restarting):
https://superuser.com/a/289788/300519
https://superuser.com/a/204916/300519
https://superuser.com/a/321469/300519
https://superuser.com/a/372396/300519
https://superuser.com/a/542863/300519
Can't delete folder and I am admin. "You need permission to perform this action. You require permission from..."
Can't delete folder and I am admin. "You need permission to perform this action. You require permission from..."
This works: https://superuser.com/a/204934/300519, but my original post is asking how to get around this specific hack...

My setup: OSX Mountain Lion, Parallels, Windows 7 VM, Visual Studio Ultimate 2013

The problem that I have is that when I open Visual Studio to make a new solution/project, whether or not I add files or work for however long, then close Visual Studio completely, and I want to delete the root solution/project folder that was created by Visual Studio, Windows tells me that I cannot delete that folder and tells me "You'll need to provide administrator permission to delete this folder".

However, if I go into that same root solution/project folder and delete all the files in there first, which it lets me do no problem, then back up, it then allows me to delete the root solution/project folder without issue. I have no idea how to delete that folder without going in and doing that hack. I should note that I am also a programming teacher who creates multiple solution/project folders everyday and then deletes them afterwards, so this is really getting annoying at this point.

Is there something I am missing with: Windows permissions, Visual Studio settings, special hidden files, locked files, etc. that is creating this situation?

I have asked people who use Visual Studio 2013 and Windows 7 without VM and they have never seen the issue, so I suspect it has something to do with the VM part of this...

Note: I am an administrator on both systems and installed everything myself. If I turn on the "Owner" column in Windows Explorer, it shows that I am the owner of all files created in the folder. Using Visual Studio itself, I've had no problems; only this problem exists.

Screenshots:

enter image description here

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.