4

For reasons I cannot disclose, I need to install a Linux server within a VirtualBox host running in Windows Server 2003. Unfortunately, VirtualBox fails to start, giving me an error that seems to indicate it could not build a chain of trust to the executable's certificate.

WinVerifyTrust failed on stub executable: WinVerifyTrust failed with hrc=CERT_E_CHAINING on '\Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe'(rc=-22919)

System details:

  • Operating system: Windows Server 2003 SP 1
  • Last updated: unknown
  • VirtualBox version: 5.0.0

I did do some research on my own, which pointed to a failed update. I attempted to run Windows Update to fix it, but it failed with multiple errors. I tried removing SoftwareDistribution and restarting the Windows Update server to fix this, but the errors persisted.

Another inquiry led me to this, which directed me to install the executable's certificate. I followed the article's instructions, and installed Symantec's certificate (under countersignatures) for good measure. After a reboot, my problem was still not resolved.

Finally, I tried clearing the CRL cache by running certutil -urlcache crl delete in cmd and rebooting. Unfortunately, that did not work either.

2 Answers 2

4

The WinVerifyTrust problem seems to occur due to lack of an appropriate CA root certificate installed within the Windows Trusted Root Certification Authorities store.

To solve the issue, you can try installing whichever of the VeriSign Public Primary Certification Authority root certificate(s) apply to you. For example, in my case, I required the VeriSign Class 3 Public Primary Certification Authority - G5 (Root 3) CA certificate. You'll download it as a .pem but to install it, you can change the certificate file's extension to .crt then double-click it and click 'Install Certificate'. It should automatically be installed to the appropriate certificate store.

After installation, VirtualBox 5.0.2 starts up without the WinVerifyTrust error.

2
  • 1
    Why does VirtualBox need a certificate to start up VMs?
    – Nacht
    Nov 12, 2015 at 1:47
  • 2
    @Nacht - It actually does not. It had to with the executable being signed by a certificate chain that couldn't be verified by Windows. Once executable signed Windows will require the certificate to be valid either by trusting the certificate or fixing the certificate chain itself. If an application is not signed then this requirement does not apply.
    – Ramhound
    Nov 12, 2015 at 16:02
0

If you happen to update your Windows system in the near term, you might encounter this problem.

The solution works for it is to update the version of Virtual Box to 5.0.10

VirtualBox Download Page

Not the answer you're looking for? Browse other questions tagged or ask your own question.