1

I installed fresh Win8.1 on a VM, enabled RDP access.

Problem that I'm facing is that when I close RDP client my session and all my windows and applications got closed immediately. I need session to stay on waiting for me with all my apps running.

I researched on this topic. found an article https://technet.microsoft.com/en-us/library/cc754272.aspx, tried what was suggested, but it didn't help.

I tried to connect from Win8.1 standard RDP client and from microsoft RDP client for iOS. Same behaviour. User account I use to log in is microsoft account xxx@live.com

P.S. Just in case it matters: VM is virtualbox, virtual box extensions pack is installed on guest 8.1 And I never use 'logoff', i always close RDP client with X. I do this on several other remote machines and it works flawlessly..

migrated from serverfault.com Jul 17 '15 at 22:53

This question came from our site for system and network administrators.

  • possible duplicate of Stop log off when disconnected from RDP session – austinian Jul 15 '15 at 17:11
  • How many users connect to this VM? – austinian Jul 15 '15 at 22:01
  • @austinian only 1 user connected. – Anton Viktorov Jul 15 '15 at 22:17
  • i checked event logs and potentially found a cause, but don't know how to solve this. Each time i disconnect clicking X or writing tsdiscon in console there is a line in event log saying "The Desktop Window Manager has exited with code (0xd00002fe)". i suspect that might be the cause of session being logged off. – Anton Viktorov Jul 15 '15 at 22:20
1

1 - Close the Remote Desktop Windows with the X, don't close with a logoff.

2 - Set this setting: Computer Configuration --> Administrative Templates --> Windows Components --> Remote Desktop Services --> Remote Desktop Session Host --> Session Time Limits | Enable the "Set time limit for disconnected sessions" >> Never. Watch to be sure no domain GPO overwrite your setting. (By moving the computer from OU)

  • I always close with X. I work on several remote machines - windows servers and windows7 - everything works as expected. But it doesnt work with this 8.1 machine... – Anton Viktorov Jul 15 '15 at 15:56
  • Downvoter, the OP edited is question to answer me. – yagmoth555 Jul 15 '15 at 17:32
  • @AntonViktorov Domain joined ? Be sure no domain GPO take precedence over the setting you set (Computer Configuration --> Administrative Templates --> Windows Components --> Remote Desktop Services --> Remote Desktop Session Host --> Session Time Limits | Enable the "Set time limit for disconnected sessions" >> Never) – yagmoth555 Jul 15 '15 at 17:49
  • Downvoted because OP used the term "disconnect" correctly in the title of the post. Edit history was reviewed before downvote. I thought it was clear from the context that the user was using a disconnect method of exiting RDP instead of a logoff method. There are other methods besides "click the x" to do a disconnect, also. – austinian Jul 15 '15 at 19:21
  • @austinian Thanks for the feedback. It wasn't clear at first, now it's, as I never assume, but I understand that with the current question I will be downvoted for sure. – yagmoth555 Jul 15 '15 at 19:53
1

Finally! This problem is solved now. It looks like Windows 8.1 overriding all the options you set in registry or group policies when it thinks there is not enough RAM. I had 1Gb RAM on this VM, i increased that to 1.5GB and all the options i set started working! The thing is that Windows turns off Fast User Switching in case of 1GB Ram and this influences remote sessions (even there is only 1) in such a weird way.

Thanks everyone. Anton Viktorov

0

Check the group policies related to disconnect time limit. There are two different ones: https://technet.microsoft.com/en-us/library/ee791756(v=ws.10).aspx

  • Thanks, i already looked into this. I checked that before. I actually edited both "Computer" and "User" policies. I set "never" for timeouts in both branches. Unfortunately this didn't help. – Anton Viktorov Jul 15 '15 at 20:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.