I am trying to configure Jitsi to operate as a softphone for my Telekom Germany VoIP-connection.

So, I went to the website of Telekom Germany, which provides the following details for connecting:

  • SIP-ID/User: Telephone number
  • Display name (if available): Telephone number
  • Authentification name / Username: Your login e-mail or Access Number (you get that when you book your connection)
  • Password: Your password (You again get that when you book your connection)
  • SIP-Proxy: tel.t-online.de
  • Registrar: tel.t-online.de
  • Realm: tel.t-online.de
  • STUN-Server: stun.t-online.de
  • Outbound-Proxy: leave empty or tel.t-online.de

I believe that I configured a most things correctly, because:

  • The profile got added just fine
  • I get the availability status Online.
  • If a call is incoming, Jitsi gets that and rings.

But the following does not work, while it does on other devices:

  • Making outgoing calls immediately errors as Not Acceptable.
  • Answering a call works, but I cannot hear the other side and the other side cannot hear me. The connection establishes fine though.

The error message in the log is the following:

16:56:30.867 INFO: [354] impl.protocol.sip.OperationSetBasicTelephonySipImpl.createOutgoingCall().184 Creating outgoing call to sip:[email protected]
16:56:31.483 SEVERE: [372] impl.protocol.sip.OperationSetBasicTelephonySipImpl.processResponse().620 Received error: 606 Not Acceptable

I tried the following:

  • I previously had X-Lite installed, which worked fully, with the same configuration like I use in Jitsi.
  • I use Zoiper on my iOS phone with the same configuration as in Jitsi and it works fine as well.

The error that is being thrown when making outgoing calls looks like this (as described above):

enter image description here

I have also tried various number formats:

  • +49162XXXXXXX
  • 0162XXXXXXX

Both formats cause the same error.

You can view my settings here.

  • You might also try asking on serverfault.com. VoIP issues look like they are on topic over there ...
    – DavidPostill
    Jul 18, 2015 at 15:51
  • Relevant: "SIP/2.0 488 Not acceptable here" error
    – DavidPostill
    Jul 18, 2015 at 17:40
  • Apparently it's often caused by mismatched codecs. Search for "sip 488 error outbound" for lots of interesting links...
    – DavidPostill
    Jul 18, 2015 at 17:43
  • @DavidPostill I don't think that this would be appropriate for serverfault. "Server Fault is a question and answer site for managing information technology systems in a business environment." And this sounds more like UI / usage issue
    – kluka
    Jul 18, 2015 at 23:27
  • @RAnders00: nice work on the screenshots but it would be better to add a screenshot of the account configuration in Jitsi
    – kluka
    Jul 18, 2015 at 23:30

3 Answers 3


I've solved this finally for me. The problem is, Telekom Germany does not like, when video codecs are advertised. After I've disabled every video codecs for this SIP connection, I am able to make a call outbound and not receiving error 606 Not Acceptable!

  • Thanks a lot for this info. I have spent a lot of time getting the Placetel Softphone (a fork of Jitsi) to work with both Telekom (Speedport w724v) and Placetel to work. Disabling all video codecs (onmly H.264 was selected) for the Telekom connection solved the problem with "Not Acceptable". Jun 7, 2016 at 6:06

Jitsi call failed "not acceptable"

Jitsi does support SRTP but it does so through ZRTP key negotiation. This has the advantage of providing end-to-end encryption (contrary to the standard SRTP impl in Asterisk that can be eavesdropped on the server).

It is however not supported by Asterisk and you would hence need to use an actual SIP and RTP proxy in order to have it work.

Source Jitsi configuration for SRTP

  • Sorry, I don't understand what that means and what I have to do.
    – randers
    Jul 18, 2015 at 17:30
  • 1
    Nor do I, that why I commented "You might also try asking on serverfault.com. VoIP issues look like they are on topic over there"
    – DavidPostill
    Jul 18, 2015 at 17:37
  • I just posted a possible explanation for your error. I'm sure there may be other reasons, but I'm not an expert with Jitsi (I do know a little about VoIP though).
    – DavidPostill
    Jul 18, 2015 at 17:38
  • Sorry, I did not realize it was you twice.
    – randers
    Jul 18, 2015 at 17:39

I had the same problem. The automatically configuration of jitsi uses the wrong DTMF Methode. Deutsche Telekom needs Inband.

  • Thank you very much, I will be able to test your solution in ~2 weeks.
    – randers
    Jul 25, 2015 at 17:34
  • This is not the solution.
    – randers
    Dec 31, 2015 at 17:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .