1

I have an Asus X550LN laptop (Intel i7 4500U, 8Gb Ram, Nvidia 840M), I am trying to install any Linux distribution on this laptop for a year now and I am encountering the same problem.

I downloaded Linux Mint 17 64 bit, put it on a USB flash drive via Universal USB Installer or UNetbootin, I boot into the OS and I try it out. After a few seconds the desktop stops responding to mouse clicks, I can't click on buttons or icons or anything but I can move the mouse around, even when I hover the mouse over the start menu or buttons they don't show that I am hovering over them (Like the X on a window should turn darker once you hover over it, but it doesn't). The keyboard works though, I can press the Windows key and the start menu will pop up, alt-F4 works, I can tab between text input boxes and buttons and navigate like that. The track-pad also isn't working at all.

I have tried Ubuntu, Debian, Linux Mint and others, all of them have the same problem. I tried different mice, different USB drives, different versions of the distributions, it's always the same.

Windows 8.1 works perfectly fine, the track-pad and mouse work, only Linux has this problem.

I have no idea what to do about this anymore. I don't know if it's a BIOS setting or if it's just incompatible hardware. But I'd like to figure this out before Uni starts in September.

Thanks.

  • Possible duplicate on AskUbuntu: askubuntu.com/questions/464935/… – Steven Jul 18 '15 at 23:45
  • @Steven I didn't see that, thanks for posting it. I tried disabling the touch-pad with sudo modprobe -r psmouse and it made the USB mouse work fine. It's not a solution to the problem, but at least something. I would still need the touchpad to work because I don't have a mouse with me at all times or when the lappy is on my lap. – Vanix Jul 19 '15 at 0:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.