2

I was running a working pptp server months ago. After tried and failed l2tp server, I wanted to go back to pptp. But for some reason it won't work any more. I cannot even find the data log for the pptpd.

I am using Ubuntu 15.04. I setup iptables to accept tcp 1723+ gre ACCEPT tcp -- anywhere anywhere tcp dpt:ssh ACCEPT tcp -- anywhere anywhere tcp dpt:1723 also has sysctl net.ipv4.ip_forward=1 net.ipv4.conf.all.accept_redirects = 0 net.ipv4.conf.all.send_redirects = 0

When I tried to connect to the pptp server using my android phone, I got unsuccessful after a few seconds.

And I remember there was a data log could be checked even with failed connection, but I can not find it anymore. I tried /var/log/auth.log and ./messages

I think if I can find the datalog for pptpd, it might help me debug..

my pptpd.conf option /etc/ppp/pptpd-options logwtmp localip 192.168.0.111 remoteip 192.168.0.10-15

also, I am using wlan0 as single interface

After everytime I tried to connect to the server, I see the iptables -L -v shows the number of bytes of tcp 1723 increase by about 60

  • Finally I re-installed ubuntu and the problem was solved.. – chrisky Jul 23 '15 at 7:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.