2

I have a case of one machine out of several incorrectly reporting the MIME type of any image uploaded via a web form in Internet Explorer 11 only as 'application/....' rather than 'image/....' as on every other machine, or indeed either Chrome or Firefox on the same machine. This is breaking a web application which only allows uploading of 'image/...' MIME types.

My first guess was maybe the application associated with the files could be the culprit, but changing this did not make a difference. Other things tried have been restarting the machine, and also resetting the browsers settings.

This machine is using Windows 7, but perhaps this happens on other releases too.

Does anyone have any ideas on both how to change this to the standard MIME type, and also what may have caused this in the first place?

  • 1
    Does it report the file size incorrectly too? – Dave Jul 20 '15 at 9:30
  • They are exactly the same size. I have created a micro-test which displays what the browser reports: codepen.io/MattyBalaam/full/BNPeJw – Matty Balaam Jul 20 '15 at 10:23
  • Now I'm lost... is the issue with an application you created (which you programmed)? – Dave Jul 20 '15 at 11:08
  • You are correct. However, I believe that this is an issue with either the OS or Internet Explorer, not related to any programming issue. I have found a server-side php, rather than client-side javascript checker which also reports the same type results: mime.ritey.com – Matty Balaam Jul 20 '15 at 16:05
1

We had this issue recently, the cause was Autodesk Pixlr it had overwritten the String value Content Type from "image/jpeg" to "application/jpeg" in registry HKLM\SOFTWARE\Classes.jpg.

Uninstalled Autodesk Pixlr but it actually deleted the Content Type values rather than restoring to image/*.

Used Regshot to compare registry before and after installation of Autodesk Pixlr. Identified the changed entries below:

HKLM\SOFTWARE\Classes.bmp\Content Type: "application/bmp" HKLM\SOFTWARE\Classes.gif\Content Type: "application/gif" HKLM\SOFTWARE\Classes.jpeg\Content Type: "application/jpeg" HKLM\SOFTWARE\Classes.jpg\Content Type: "application/jpg" HKLM\SOFTWARE\Classes.png\Content Type: "application/png" HKLM\SOFTWARE\Classes.tif\Content Type: "application/tif" HKLM\SOFTWARE\Classes.tiff\Content Type: "application/tiff"

So uninstalled it again, backed up registry and created the correct entries below:

HKLM\SOFTWARE\Classes.bmp\Content Type: "image/bmp" HKLM\SOFTWARE\Classes.gif\Content Type: "image/gif" HKLM\SOFTWARE\Classes.jpeg\Content Type: "image/jpeg" HKLM\SOFTWARE\Classes.jpg\Content Type: "image/jpeg" HKLM\SOFTWARE\Classes.png\Content Type: "image/png" HKLM\SOFTWARE\Classes.tif\Content Type: "image/tiff"
HKLM\SOFTWARE\Classes.tiff\Content Type: "image/tiff"

This resolved the issue.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.