I just received a new Dell Vostro notebook. The touchpad works fine when I boot into setup, or a Windows install DVD, but with Fedora 22 workstation (live and installed), the mouse pointer appears but trying to move the pointer or clicking the touchpad buttons does not work. I plug a USB mouse into a port to work around the issue. I would like to get the touchpad working.

Here is a snippet from journalctl:

(II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event7)
(**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
(**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
(**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
(**) SynPS/2 Synaptics TouchPad: Applying InputClass "libinput touchpad catchall"
(II) systemd-logind: got fd for /dev/input/event7 13:71 fd 27 paused 0
(II) Using input driver 'libinput' for 'SynPS/2 Synaptics TouchPad'
(**) SynPS/2 Synaptics TouchPad: always reports core events
(**) Option "Device" "/dev/input/event7"
(II) input device 'SynPS/2 Synaptics TouchPad', /dev/input/event7 is tagged by udev as: Touchpad
(II) input device 'SynPS/2 Synaptics TouchPad', /dev/input/event7 is a touchpad
(**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input6/event7"
(II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 14)
(**) Option "AccelerationScheme" "none"
(**) SynPS/2 Synaptics TouchPad: (accel) selected scheme none/0
(**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
(**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
(II) input device 'SynPS/2 Synaptics TouchPad', /dev/input/event7 is tagged by udev as: Touchpad
(II) input device 'SynPS/2 Synaptics TouchPad', /dev/input/event7 is a touchpad
(II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
(II) No input driver specified, ignoring this device.
(II) This device may have been added with another device file.

And here is a dnf command output that shows the drivers installed:

$ dnf list *synaptics*
Fedora 22 - x86_64                              1.9 MB/s |  41 MB     00:21    
Fedora 22 - x86_64 - Updates                    1.2 MB/s |  12 MB     00:10    
Last metadata expiration check performed 0:00:10 ago on Sun Jul 19 23:53:39 2015.
Installed Packages
xorg-x11-drv-synaptics.x86_64                   1.8.2-2.fc22             @System
Available Packages
xorg-x11-drv-synaptics-devel.i686               1.8.2-2.fc22             fedora 
xorg-x11-drv-synaptics-devel.x86_64             1.8.2-2.fc22             fedora 

From what I understand, in Fedora there is no longer a xorg.conf to program as everything is autodetected by default. Since it is not, I would appreciate suggestions on what to do.

EDIT 1 - Clarified that the mouse pointer appears on Fedora 22 boot, but cannot be moved or clicked.

EDIT 2 - Including most of Xorg.0.log from after the suggested grub change.

EDIT 3 - Deleted Edit 2 - It looks like that was a red herring and that the touchpad is actually being detected.

$ xinput
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ DLLC6C1:00 06CB:796A                      id=12   [slave  pointer  (2)]
⎜   ↳ HID 062a:0001                             id=16   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=14   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ Integrated_Webcam_HD                      id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=15   [slave  keyboard (3)]

Aaargh. I tried to enable/disable the touchpad via xinput CLI and also through the gnome settings interface. No effect, its always off Tried the live version of Ubuntu and saw the same thing. After some googling. I found a that it might be turned off within the hardware. The Dell Vostro 3558 has no keyboard Fn key for the touchpad, but I read to install Windows and the dell synaptics driver, disable the touchpad, enable it, save settings, cut the power and boot fedora. I tried that and the result was the same. Off or on the touchpad does nothing

I guess I need to know how can I troubleshoot why turning the touchpad on/off has no effect and it is always off.


It seems all Dell laptops ship with Synaptics trackpad. Newer laptops use a protocol called I2C-HID instead of PS/2. I've read somewhere that the i2c-hid protocol was defined by Microsoft.

Based on what I've read from numerous posts about "trackpad not working in (insert distro name here)", some possible solutions to this issue are (choose one):

  • Blacklist the i2c-hid module by adding an entry in /etc/modprobe.d/blacklist.conf. Add "blacklist i2c-hid".
  • Upgrade Linux kernel to 4.1 or greater
  • Manually install Synaptics i2c-hid module for your distro

Blacklisting the i2c module seems to be the easiest and fastest solution. However, there may be some unintended consequences if you do that.

Here's an excerpt I've read from RedHat Bugzilla:

Matt Hirsch 2014-11-24 06:50:02 EST

I have a Dell Inspiron 13 7000 series. It has one of these new synaptics touchpad that are described above, with both a ps2 and hid mode. I'm running Fedora 21, kernel-3.17.3-300.fc21.x86_64. If I blacklist the i2c_hid module, the trackpad works as expected, and I can also use the touchscreen.

However, I can't properly suspend the system. It immediately wakes up again. If I insert the i2c_hid module, I can suspend the system properly, but I cannot right click by pressing in the bottom right of the trackpad -- I have to press with two fingers.

  • Thank you very much @joffreyca, my touchpad now works. Just a few comments, I am running Fedora 22, kernel 4.1.6. I added blacklist i2c_hid to /etc/modprobe.d/blacklist.conf and I also added rdblacklist=i2c_hid to the kernel line in grub. Did a poweroff/reboot and it is working fine now. – John W Sep 4 '15 at 20:19

Try the following, which worked for me for the same problem on another flavour of Linux:

# modprobe -r psmouse && modprobe psmouse
  • Thank you Simon, but it did not help. Response at the command line was modprobe: FATAL: Module psmouse is builtin. I tried it without the -r and got no error, but it did not fix the issue either – John W Jul 21 '15 at 16:12
  • Ok edit your /etc/default/grub file and add “psmouse.proto=imps” to GRUB_CMDLINE_LINUX e.g. GRUB_CMDLINE_LINUX="rd.lvm.lv=vg00/swap rd.lvm.lv=vg00/root quiet psmouse.proto=imps” Then update grub with grub2-mkconfig -o /boot/grub2/grub.cfg or grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg if you’re using EFI. Then reboot. It worked for me on Fedora 22. – Simon Hoare Jul 22 '15 at 7:21
  • Thank you again for your suggestion Simon, but unfortunately had the same result. I will edit my question with the full xorg log from after the grub change, maybe this will offer additional information. – John W Jul 22 '15 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.