0

For a few months now I keep being bugged by Windows about restarting my PC to repair errors the most annoying thing is that even if I restart nothing happens(didn't try this with the SSD yet) I even tried running Chkdsk by hand with no success.

I've changed 2 HDDs by now (didn't trow them away just turned them into external HDDs), but every time I do it seams ok for a week or two after which I get the message again.

I've bought a new SSD(for about 3 weeks) and yesterday I started getting the message again even though the utilities for it say that everything is ok.

My laptop is a Toshiba Sattelite and I'm running Windows 8.1

What's wrong with it ? Should I be worried that something on this laptop is damaging my drives ?

5
  • It could be a bad hard drive to motherboard cable, or a failing motherboard. – Moab Jul 20 '15 at 18:06
  • @Moab anyway I can check this ? A tool maybe or something ? – Bobby Tables Jul 20 '15 at 18:07
  • No, replace the cable to see if it solves it, not much you can do if it is the motherboard. Outside possibility it could be a memory module is flaky, test the memory using this software. – Moab Jul 20 '15 at 18:30
  • What was the exact message you were getting? Were there any entries in your event log that pointed to problems? – ssnobody Jul 20 '15 at 19:21
  • Yes, dig through the Event logs in Window to see if they say anything related. eventvwr.msc > Windows Logs > System probably. – Datarecovery.com MK Jul 20 '15 at 20:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.