3

I use Windows 8.1. My Mozilla Firefox 39.0 (abbreviated to FF) comprises many add-ons, one of which is AdBlock Plus 2.6.9.1 (abbreviated to ABP). Certain websites contain links such as 'Share on Facebook' (SOF) or 'Share on Twitter' (SOT) (call these links buttons). Clicking these buttons should open another separate browser window that already will have, displayed and prepared to be posted, the social media page and the message box.

  1. Even with ABP operational, buttons for 'Share on Twitter' still operate normally.

  2. Despite disabling ABP on all such websites, buttons for 'Share on Facebook' fail; nothing pops up. So what's the problem? The problem seems limited to ''Share on Facebook'.

Reply to user 'Inkbug': The following refers to about:preferences#content in FF.

  1. After 1 and 2, I added the aforementioned websites to Exceptions, but the buttons still fail.

  2. After 3, I disabled FF's blocker by deselecting Block pop-up websites, but the buttons still fail.

Reply to user 'Loic' below: 5. As advised, I pressed F12 to display FF's console, but it's blank.

Reply to user 'MC10': 6. This implies only one way to block buttons, but I never enabled (or knew of) this filter, before you commented on it.

Reply to user 'DavidPostill': 7. SOF fails for the following websites for contest entries, which require one to register and enter first, but I do not expect or intimate this for anyone:

8. Both SOF and SOT are missing on the right of 'SHARE FOR AN EXTRA ENTRY'.
9. For both of these websites, SOF appears, but fails to produce a popup.

Reply to user 'Jaime Santa Cruz': This problem vanishes and ceases in FF's Safe Mode!
Finally, a positive and successful, but temporary, solution! But what's the problem?

  • in about:preferences#content, there is a setting for enabling and disabling Firefox's built in popup blocker. This blocker is unrelated to AdBlock Plus. – Inkbug Jul 21 '15 at 6:47
  • Thanks, but alas, your answer didn't resolve the problem. Please see my OP. – Greek - Area 51 Proposal Jul 21 '15 at 11:55
  • First you may check your popup blocker settings: support.mozilla.org/en-US/kb/… Otherwise, is it possible that some Javascript code related to facebook is blocked? Do you have a web blocker, or are you connecting from a corporate network? To investigate: Press F12 it will display Firefox console to investigate: any error is displayed? Chose Network and then refresh the page. Any error or unsatisfied request? By looking at the console you will see what's wrong. – Loic Jul 30 '15 at 9:18
  • 1
    Does the behavior persist in Firefox Safe Mode? – Jaime Santa Cruz Aug 2 '15 at 21:47
  • 1
    The problem might be troubleshooted by disabling all extensions and then enabling them one by one. You mentioned you have many add-ons, which are disabled on Safe Mode; it is impossible to pinpoint which one might me having problems without a full list, and even then, we will need the exact configuration of each. Other factors may be in play (malware, for instance). – Jaime Santa Cruz Aug 3 '15 at 1:46
2
+50

If the behavior does not persist on Firefox Safe Mode, as stated, the problem might be troubleshooted by disabling all extensions and then enabling them one by one. You mention you have many add-ons, which are disabled on Safe Mode; it is impossible to pinpoint which one might be having problems without a full list, and even then, the exact configuration of each will be required. Other factors may be in play (malware, for instance).
I would perform a full reinstall, taking care of removing the default user folder; which may perpetuate your problem.

  • Thank you. Allow me to wait towards the end of the bounty period. If no better answer emerges, I'll award you the bounty. – Greek - Area 51 Proposal Aug 4 '15 at 17:50
0

I had a similar issue with Firefox 40.0.2 on Windows 8.1. Share buttons would open another window but it would remain blank. Same thing with extension Hootlet. As suggested by Jaime, I disabled all my extensions, and reactivated them one by one to find the faulty one.

It happened to be Ghostery.

Note that stopping blocking would not solve the issue: I had to deactivate Ghostery completely.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.