0

I'm trying to execute command via remexec on my VM.

VM has own IP address, and it's pinged, and even shared folder is working via IP.

But remexec fails:

C:\Users\User>remexec 192.168.72.133 -q -t 6000 -l admin -p admin "c:\temp\test.bat"
Opening connection to 192.168.72.133 failed: 10060

Any ideas? What could be wrong and how to fix?

Ping:

>ping 192.168.72.133

Pinging 192.168.72.133 with 32 bytes of data:
Reply from 192.168.72.133: bytes=32 time<1ms TTL=128
Reply from 192.168.72.133: bytes=32 time<1ms TTL=128
Reply from 192.168.72.133: bytes=32 time<1ms TTL=128
Reply from 192.168.72.133: bytes=32 time<1ms TTL=128

Ping statistics for 192.168.72.133:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

VM ip config:

C:\temp>ipconfig -all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : VMHost
   Primary Dns Suffix  . . . . . . . : domen.x
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : domen.x

Ethernet adapter Local Area Connection 3:

   Connection-specific DNS Suffix  . : localdomain
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : <hidden for security reason>
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::c08:71ca:327b:df7f%17(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.72.133(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 20. july 2015 11:19:10
   Lease Expires . . . . . . . . . . : 21. july 2015 11:25:29
   Default Gateway . . . . . . . . . :
   DHCP Server . . . . . . . . . . . : <hidden for security reason>
   DHCPv6 IAID . . . . . . . . . . . : <hidden for security reason>
   DHCPv6 Client DUID. . . . . . . . : <hidden for security reason>

   DNS Servers . . . . . . . . . . . : 192.168.72.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

2 Answers 2

1

Some ideas

  • Use RPCPing to ensure RPC ports are open
  • Temporarily disable firewall
  • Try PSEXEC from Sysinternals. Ths command to try is :\\PSEXEC 192.168.72.133 -c -d -f -u admin -p admin "c:\temp\test.bat"
5
  • RPCPing OK. Firewall already disabled (UAC disabled). PSEXEC fails with "PsExec could not start 192.168.72.133: The system cannot find the file specified." with any command.
    – Ksice
    Commented Jul 21, 2015 at 9:46
  • OK, 'PSEXEC \\192.168.72.133 cmd' opened cmd for me, so it works. Then what's wrong with remexec??
    – Ksice
    Commented Jul 21, 2015 at 9:51
  • And the same with '-c -d -f -u admin -p admin' options gave me "Access is denied." error. Why? Credentials are correct.
    – Ksice
    Commented Jul 21, 2015 at 9:54
  • The editor removed my backslashes, sorry. Do not know, might be antivirus. I would use the command I posted with backslashes to copy and start batch file remotely Commented Jul 21, 2015 at 9:54
  • Thanks. '-c -d -f' used to copy local file. With "cmd" it's not possible. But otherwise psexec works. But my problem still exists. I need remexec, not psexec to be used.
    – Ksice
    Commented Jul 21, 2015 at 9:58
0

Problem solved. It turned out that the firewall has not been disabled. Solved by adding rule to port 512 that is running the service application.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .