On a fresh OS X Yosemite 10.10 box, when I tried to run Eclipse Mars, I got the usual "You need Java 1.6, Click More info" box. I followed the link and installed the Apple maintained 1.6.x package.
Then I tried to restart Eclipse and it told me that it needed > Java 1.7 to run. I installed Oracle's 1.8 JDK but Eclipse still complains that it needs > 1.7.
If I run
java -version it still shows as 1.6.