3

On a fresh OS X Yosemite 10.10 box, when I tried to run Eclipse Mars, I got the usual "You need Java 1.6, Click More info" box. I followed the link and installed the Apple maintained 1.6.x package.

Then I tried to restart Eclipse and it told me that it needed > Java 1.7 to run. I installed Oracle's 1.8 JDK but Eclipse still complains that it needs > 1.7.

If I run java -version it still shows as 1.6.

1

You need to remove the Apple maintained Java 1.6 install and re-install the Oracle 1.8 JDK.

Uninstall can be performed by following https://superuser.com/a/712783/161924 or by simply:

sudo rm -rf /System/Library/Java/JavaVirtualMachines/1.6.0.jdk 

Then reinstall JDK 1.8 from http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

Eclipse will now start. java -version will now report:

java version "1.8.0_51"
Java(TM) SE Runtime Environment (build 1.8.0_51-b16)
Java HotSpot(TM) 64-Bit Server VM (build 25.51-b03, mixed mode)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.