3

I've just tried installing Visual Studio 2015 RTM on my Windows 8.1 computer. The installation proceeded without any problems, but afterwards I had multiple issues:

  • Visual Studio 2015 itself wouldn't launch: it would crash with a Debug dialog on startup.
  • Visual Studio 2013, which was previously working, also started crashing on startup.
  • Event Viewer wouldn't load, but no error message was shown. If I launched MMC and tried adding it as a snap-in, it would crash with a Debug dialog.

In the end, I had to use System Restore to go back to the point immediately before installing VS 2015. Everything seems to be back to normal now.

Update: I spoke too soon - even after the system restore I started getting crashes. In the end I re-installed my OS (this was before I'd seen the answers below).

If I look in the Event Viewer at the times when I was trying to launch Event Viewer previously, I'm seeing a .Net Runtime error from each occasion with the message

Application: mmc.exe Framework Version: v4.0.30319 Description: The process was terminated due to an internal error in the .NET Runtime at IP 00007FFD67E94745 (00007FFD67CC0000) with exit code 80131506.

For the times when I tried to launch Visual Studio I'm seeing an Application Error with the details

Faulting application name: devenv.exe, version: 14.0.23107.0, time stamp: 0x559b7ead Faulting module name: clr.dll, version: 4.6.81.0, time stamp: 0x5584e56f Exception code: 0x80131506 Fault offset: 0x002cdc9a Faulting process ID: 0x2108 Faulting application start time: 0x01d0c3a28aeed79f Faulting application path: C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\devenv.exe Faulting module path: C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr.dll Report ID: c8ca7216-2f95-11e5-80de-002564d97fd2 Faulting package full name: Faulting package-relative application ID:

I'm also seeeing a .Net Runtime error

Application: devenv.exe Framework Version: v4.0.30319 Description: The process was terminated due to an internal error in the .NET Runtime at IP 748DDC9A (74610000) with exit code 80131506.

Has anybody else seen this and been able to fix it?

1

So the workaround to this issue as described in the link at https://support.microsoft.com/en-us/kb/3065367 is as follows:

Delete the registry key AltJit found at HKEY_CURRENT_USER/Software/Microsoft/.NETframework/AltJit

Additionally, make sure that the COMPLUS_AltJit environment variable is not set.

0

Have you installed one of the RyuJIT CTPs? I found a Microsoft blog post saying that .NET apps are known to crash on startup if you have a RyuJIT CTP installed and then you upgrade to .NET 4.6 (which comes with VS 2015).

http://blogs.msdn.com/b/clrcodegeneration/archive/2015/05/27/ryujit-and-net-4-6.aspx

  • Can you post the relevant information from the url into the answer? – Ramhound Jul 21 '15 at 16:22
  • Here is a perfect resource to actually answer the question in detail instead of just providing a link. – Ramhound Jul 21 '15 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.