2

I have an USB device (eGalax Toucscreen controller) that won't work if the computer is powered on with the device plugged (' device not accepting address').

It however works, if plugged in after the machine is powered. It keeps working then even after restart, as long as the power is not cut.

On the other hand, if it was plugged on power on, it would not work, even after restart.

I guess the BIOS is putting the device in some condition it won't recover on cold start.

I already tried several kernel versions and BIOS settings (EHCI and XHCI takeover fixes for example), but the problem remains. I also tried other devices of the same kind. I've used these devices for quite some time with other setups, but could reproduce this behaveor on two different machines.

How to troubleshoot this condition?

  • This behaveour even holds when the device is connected by an USB hub. – dronus Jul 21 '15 at 16:21
  • What output do you see in dmesg relevant for this device after booting? – l0b0 Jul 21 '15 at 16:38
  • someone here at serverfault.com/questions/194991/… suggested to use modprobe. See if it helps – pun Jul 21 '15 at 16:42
  • dmesg says like [ 1.547635] usb 1-6: new low-speed USB device number 5 using xhci_hcd [ 1.549013] usb 1-6: Device not responding to setup address. [ 1.955468] usb 1-6: device not accepting address 5, error -71 – dronus Jul 21 '15 at 18:00
  • modprobe does not help, as all usb modules ehci, xhci and ohci are built into kernel on Ubuntu 14.04. – dronus Jul 21 '15 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.