14

In the Mac client for Slack, I'd like to be able to change the fonts and colors for messages (e.g. have all messages / text in the message area be white text on a black background, or be a larger font, etc.).

Unfortunately, editing the index.html CSS under the Content/Resources directory in Slack.app only changes aspects of the splash screen.

Is it possible to modify these styles, and (if so), how would I accomplish that?

P.S: I wanted to create a slack tag, because apparently one doesn't already exist. But my rep is apparently too low. Sadness ensued.

  • 1
    A slack tag now exists. Bob would be proud... – Parthian Shot Mar 3 '16 at 16:03
  • Over 1,000 people looked at this, and only two people who viewed it also had this question? My apologies to the > 99.8% of you who were looking for a different question. – Parthian Shot Mar 14 '16 at 13:23
3

As far as I know, Slack for OSX does not support customization of fonts or colors in the message area. You may make the font larger or smaller via the standard <Cmd>+ and <Cmd>- keystrokes.

You may, however, customize the sidebar portion of Slack, on a per-team basis.

From the Zendesk help page:

Choosing a new theme

1. Open the Slack team you’d like to customize.
2. Go to the Team Menu by clicking the down arrow next to your team’s name.
3. Select Preferences.
4. Click Sidebar Theme.
5. Choose a sidebar theme. To select custom colors, click customize your theme and share it with others.
6. When you’re finished, click Done.  

This will not change your message window, just the sidebar theme.

  • Unfortunately, as of Nov 2016, the "standard <Cmd>+ and <Cmd>- keystrokes" no longer work. – Max Nov 3 '16 at 18:45
  • 1
    @Max works for me – warvariuc Nov 12 '16 at 10:44
  • @warvariuc I believe this is a bug when you have multiple teams. FWIW I'm running version 2.3.0. – Max Nov 15 '16 at 4:34
  • @Max I am also using 2.3.0. Try menu View -> Zoom In/Out – warvariuc Nov 15 '16 at 11:31
  • I've tried, and 75% of the time, nothing. I tweeted to Slack too, they said it sounds like a bug, probably something obscure that only happens with my setup. Oh well, thanks for the help anyways. – Max Nov 16 '16 at 20:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.