5

Usually I can figure this stuff out on my own, but I am stumped with this one:

When trying to open portal 2 in steam, I get the preparing to launch portal 2 message, the message closes, then nothing. The game does not launch, there are no error messages. I tried verifying the game files, with success. But I still cannot launch portal. I tried running the portal2.sh file in the terminal. here is the output:

libGL error: unable to load driver: nouveau_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: nouveau
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
SDL video target is 'x11'
SDL video target is 'x11'

SDL failed to create GL compatibility profile (whichProfile=0!
SDL failed to create GL compatibility profile (whichProfile=0!

PROBLEM: You appear to have OpenGL 1.4.0, but we need at least 2.0.0!
Could not find required OpenGL entry point 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be updated.
Could not find required OpenGL entry point 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be updated.

I can play Team Fortress 2 just fine, so I don't think openGL is the issue. I read somewhere that updating video card drivers might help, but I can't figure out how to update my drivers on ubuntu. my video card is: NVIDIA Corporation GT218 [GeForce 8400 GS Rev. 3] (rev a2)

UPDATE: I just confirmed I have openGL 10.3.2. This easily fits portal 2's requirement of 2.0.0 or later.

9

I had this problem on 64 bit Ubuntu 14.04 and fixed it by doing the following

  1. Delete SteamApps/common/Portal 2/bin/libstdc++.so.6
  2. Run the Steam client
  3. cd "SteamApps/common/Portal 2"
  4. LD_LIBRARY_PATH=bin ./portal2_linux -game portal2 -windowed

After running it once this way I could start it from the normal library window

I am sorry that I do not remember the attribution of this answer, but you may be able to google it up if you wish.

  • 1
    i have been trying to get this to work for over a year now. After a year of research that was all i had to do!!! – Gman Smith Jul 21 '15 at 22:37
  • Today was your lucky day then @GmanSmith. I have never looked at Super User before...I joined just to answer your question :) – Organic Marble Jul 21 '15 at 22:39
  • 2
    Same issue after a Steam update (Ubuntu 16.04 / 64 bits). Organic Marble's step 1 fixed it without having to do steps 2-4. Simply deleting .steam/steam/SteamApps/common/Portal 2/bin/libstdc++.so.6 – Maze Dec 17 '16 at 6:30
  • 1
    Just deleting that file fixed it, no need to specify those launch options. How did you figure that out though?! – Luc Feb 26 '17 at 20:04
  • It was a couple of years ago; I'm sorry, I do not remember. – Organic Marble Feb 26 '17 at 20:25

protected by Community Jan 16 '18 at 6:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.