When I save a file in a desktop (Windows) Office application, Office attempts to upload the file to my OneDrive account. It does this every time I save. This works about 90% of the time. The other 10% of the time, the file gets stuck uploading (for whatever reason) and sometimes crashes office.

Uploading to OneDrive

I use OneDrive (I'm running windows 8.1 with Update) to sync my documents to my OneDrive cloud storage. I'd rather just have my desktop office applications save the files to my local OneDrive folder, and let the OneDrive app sync the file when it sees that the file has been updated.

Is there a way to turn off this automatic upload from within Office 2013? I have looked through settings within the Office Upload Center and within MS Word and have yet to find a way to disable this "upload on save" functionality.

Edit: I tried to right-click the OneDrive icon in the taskbar's notification area and chose Settings. These are the options, none of which seem appropriate:

OneDrive Notification Icon Settings

Look for the OneDrive icon in the System Tray (bottom RH corner of the screen). Right click and select Settings. On the Settings, goto office Tab and uncheck "Use Office to sync office files". Reboot. Cross fingers.

You will get your life back.

  • Thank you so much. I have been looking for this for a long time (strangely google didn't help much here) – nassimhddd Jan 9 '17 at 12:23

Okay, here's an idea.

Delete the following file:

C:\Program Files\Microsoft Office\Office15\MSOSYNC.exe

Source: http://www.technotrickies.com/2014/10/how-to-disable-auto-start-of-microsoft.html

Edit: Apparently, new location of MSOSYNC is C:\Program Files\Microsoft Office\root\Office16 (thanks to @feetwet)

  • Or rename the file to MSOSYNC.exe.bak so you can restore it if need be. – misha256 Jul 22 '15 at 3:41
  • +1 This answer will actually work. There are also other similar ways to achieve the desired result, almost all of them are presented here: superuser.com/questions/560972/… – misha256 Jul 22 '15 at 3:48
  • Shoot: This does not seem to work on the latest version of Office (365 or 2016): Some update process brings a copy back! – feetwet Mar 6 at 16:10

Possibly this:

Right-click the SkyDrive icon in the notification area, at the far right of the taskbar. (You might need to click Show hidden icons first to see the icon.) Then click Settings. On the Settings tab, under General, deselect Use Office to sync files faster and work on files with other people at the same time, and then click OK.

Credit to geek-o-matic

http://answers.microsoft.com/en-us/office/forum/office_2013_release-office_storage/how-to-disable-microsoft-upload-center-2013/8bbc93e6-bc3b-4414-a1d3-9f37c3ed2d6e

  • That didn't work because on right-clicking the OneDrive icon in the notification area and choosing Settings, I receive a Window with two tabs: Settings and More Info. There is no General heading under the Settings tab. – Shaun Luttin Jul 22 '15 at 3:26
  • @ShaunLuttin Damn, my mistake, I didn't quite click onto the fact that you're running Windows 8.1 which makes a huge difference to how SkyDrive works. Not sure who up-voted me :-p – misha256 Jul 22 '15 at 3:44

Right click the Office Upload center icon in taskbar and click pause. Solved the prob for me for now at least.

Pause uploads

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.