1

I found out that start.exe might be useful as a tool intended to run installed programs. So I can run Word:

start winword # located in "C:\Program Files\Microsoft Office 15\root\office15\WINWORD.EXE"

Visual Studio:

start devenv # located in "C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\devenv.exe"

Skype

start skype # located in "C:\Program Files (x86)\Skype\"

Waterfox

start waterfox #located in "C:\Program Files\Waterfox\waterfox.exe"

and even Notepad++

start notepad++ # located in "C:\Program Files (x86)\Notepad++\notepad++.exe"

But it does not work for steam,

PS C:\Users\Павел> start steam
start : This command cannot be run due to the error: The system cannot find the file specified.
At line:1 char:1
+ start steam
+ ~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (:) [Start-Process], InvalidOperationException
    + FullyQualifiedErrorId : InvalidOperationException,Microsoft.PowerShell.Commands.StartProcessCommand

however :

>Test-Path 'C:\Program Files (x86)\Steam\Steam.exe'
True

my $PATH:

/usr/local/bin:/mingw/bin:/bin:/c/Program Files/Far Manager:/c/Program Files/Far Manager/ConEmu:/c/Program Files (x86)/ActiveState Komodo Edit 9/:/c/Python34/:/c/Python34/Scripts:/c/Perl64/site/bin:/c/Perl64/bin:/c/Program Files (x86)/ActiveState Komodo Edit 8/:/c/Windows/system32:/c/Windows:/c/Windows/System32/Wbem:/c/Windows/System32/WindowsPowerShell/v1.0/:/c/Program Files/Microsoft SQL Server/110/Tools/Binn/:/c/Program Files/Microsoft SQL Server/120/Tools/Binn/:/c/Program Files (x86)/CMake/bin:/c/Program Files (x86)/Windows Kits/8.1/Windows Performance Toolkit/:/c/Program Files (x86)/Microsoft SDKs/TypeScript/1.0/:/c/Program Files/SlikSvn/bin:/c/Program Files (x86)/Skype/Phone/:/c/Program Files (x86)/NVIDIA Corporation/PhysX/Common:/c/ProgramData/chocolatey/bin:/c/Program Files (x86)/GitExtensions/:/c/Ruby21/bin

(I used Git Bash to show it because PowerShell seems to shorten this long variable when I run gci) How can I run Steam that way?

EDIT: It also does not work for VLC in the default installation

  • Let me guess, you used Chocolatey to install all of those programs except Steam? Chocolately is adding them to path, start is not doing anything special. – heavyd Jul 22 '15 at 15:22
  • Even though I can run skype without start, I can't run notepad++, devenv, winword and waterfox. It definitely does something special – pashazz Jul 22 '15 at 15:38
  • My guess is that the ++ in notepad++ is not being parsed correctly by the shell, but when its passed as an arguement to start there's no problem. – heavyd Jul 22 '15 at 15:44
  • What about other commands? Look $ winword sh.exe": winword: command not found but start winword does work – pashazz Jul 22 '15 at 16:00
  • In powershell its behaviour is the same – pashazz Jul 22 '15 at 16:01
3

Check your registry App Paths subkeys. It's located in HKCU and HKLM under Software\Microsoft\Windows\CurrentVersion\App Paths. Dont forget about 32bit and 64bit keys in HKLM.

The idea is that some application's installers create these keys, but others don't.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.