2

I tried to back up my C:\Windows\Fonts folder by copying it. That gave me a "Fonts - copy" folder. I deleted that folder and now the properties of the original "Fonts" folder have changed.

I believe this to be causing problems with some programs, specifically Chrome.

On a normal system, when I look at C:\Windows\Fonts folder through File Explorer it has a little "A" on it. The properties window shows only the one tab, "General." And when I go to the command prompt in C:\Windows and type dir, "Fonts" does not show up as a file or a directory. Is it a link of some sort?

But on the messed-up system, C:\Windows\Fonts does not have the little A on the folder, the properties window shows three tabs ("General", "Sharing", and "Security"), and when I use the command prompt "Fonts" does show up as a folder.

I've tried "Restore default font settings" in Control Panel's "Font settings" window, but this does not seem to restore the properties of the "Fonts" folder.

How can this be fixed? Is there a way to reestablish the original C:\Windows\Fonts folder properties without reinstalling the OS?

2
  • System Restore?
    – DavidPostill
    Jul 22, 2015 at 20:55
  • Tried this but I was blocked by System Restore error 0x80070005 and ran down several rabbit trails stemming from that.
    – bigLarry
    Jul 24, 2015 at 20:43

1 Answer 1

1

It sounds like your Fonts folder lost its desktop.ini, which is part of what makes it special. Open an administrative command prompt, navigate to C:\Windows\Fonts, then type the following commands:

  1. echo. > desktop.ini to create a blank file named desktop.ini
  2. notepad desktop.ini to open that file in an administrative Notepad instance

Paste the following into that Notepad window, then save:

[.ShellClassInfo]
CLSID={BD84B380-8CA2-1069-AB1D-08000948F534}

Log off and back on. If that didn't fix your problem, then the Registry lost its entries for the Fonts shell folder, which is another component that makes it special. Open a new instance of Notepad (not administrative) and paste this into it:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\CLSID\{BD84B380-8CA2-1069-AB1D-08000948F534}]
@="Microsoft Windows Font Folder"
"System.Software.TasksFileUrl"="Internal"
"AppID"="{50d69d24-961d-4828-9d1c-5f4717f226d1}"
"InfoTip"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,\
  6f,00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,\
  00,53,00,68,00,65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,\
  2d,00,32,00,32,00,39,00,32,00,30,00,00,00
"LocalizedString"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,\
  6f,00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,\
  00,5c,00,73,00,68,00,65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,\
  2c,00,2d,00,32,00,32,00,39,00,38,00,31,00,00,00
"System.ApplicationName"="Microsoft.Fonts"
"DisplayName"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,\
  00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,\
  5c,00,66,00,6f,00,6e,00,74,00,65,00,78,00,74,00,2e,00,64,00,6c,00,6c,00,2c,\
  00,2d,00,31,00,39,00,39,00,00,00
"System.ControlPanel.Category"=dword:00000001
"Icon"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,\
  00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,66,00,\
  6f,00,6e,00,74,00,65,00,78,00,74,00,2e,00,64,00,6c,00,6c,00,2c,00,31,00,30,\
  00,00,00

[HKEY_CLASSES_ROOT\CLSID\{BD84B380-8CA2-1069-AB1D-08000948F534}\DefaultIcon]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
  00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,66,00,6f,00,\
  6e,00,74,00,65,00,78,00,74,00,2e,00,64,00,6c,00,6c,00,00,00

[HKEY_CLASSES_ROOT\CLSID\{BD84B380-8CA2-1069-AB1D-08000948F534}\Hierarchical]
@="0"

[HKEY_CLASSES_ROOT\CLSID\{BD84B380-8CA2-1069-AB1D-08000948F534}\InProcServer32]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
  00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,66,00,6f,00,\
  6e,00,74,00,65,00,78,00,74,00,2e,00,64,00,6c,00,6c,00,00,00
"ThreadingModel"="Apartment"

[HKEY_CLASSES_ROOT\CLSID\{BD84B380-8CA2-1069-AB1D-08000948F534}\ShellFolder]
"Attributes"=dword:a0000000
"WantsForParsing"=""

(I just exported the branch of my Registry that deals with the Fonts special folder. You can check that against the appropriate branch of a clean Registry if you're paranoid.)

Save the file with a .reg extension, then double-click it in Explorer. Confirm the Registry merge and restart your computer.

3
  • Got an error trying to merge: "Cannot import C:\Users\Derp\Desktop\thing.reg: Not all data was successfully written to the registry. Some keys are open by the system or other processes, or you have insufficient privileges to perform this operation." Tried as Administrator and in Safe mode and it didn't work.
    – bigLarry
    Jul 27, 2015 at 15:27
  • @bigLarry Were you able to create a new desktop.ini successfully? If so, try opening a new elevated command prompt, moving to the Fonts folder, and doing attrib +S +H desktop.ini.
    – Ben N
    Jul 27, 2015 at 17:04
  • Tried that. Font folder still behaves the same way. At this point I'm just going to limp along wait for an opportunity to reinstall the OS.
    – bigLarry
    Jul 31, 2015 at 18:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.