5

No matter what I do, I cannot get Windows 10 to leave my home WiFi connection as Private.

When I reboot the machine it is public, and in network settings there is no way to change this.

So instead I go into Windows Explorer and open the Network section, where I am told "Network discovery is turned off. Network computers and devices are not visible. Click to change..."

and I do, and a flyout comes from the side asking me to allow this, which I do. I go to the network settings and I see that my connection I indeed private.

15-20 minutes later, I go back to network settings, and it has changed back to Public!

I've tried changing the registry settings, I've tried changing the setting in secpol.msc (and looking at it now it is set to Private, even though the connection remains public).

I "forgot" the connection and re-added it, but it never prompts me to choose if I want to access pcs on the network it just automatically defaults it to public.

I don't see anything in the EventViewer that would explain or even log the change, and I have absolutely no idea how to fix this...

HOW DO I STOP IT FROM DOING THIS?!

Instead of getting work done for the past 2 hours I've been fighting this stupid problem. I would really appreciate any help I can get to stop this and permanently lock the connection as private...

  • If you're not using at least WPA2-PSK encryption on your home network, maybe Windows is trying to save you from yourself by treating the insecure wireless network as Public. – Spiff Jul 24 '15 at 6:37
  • definitely have wpa-psk security on the network, and none of my other machines have this problem. i thought perhaps it was due to the hyper-v virtual switches (for win10 mobile emulators) but I disabled/removed them all. this worked for a while but on next reboot is switched right back to public! – SelAromDotNet Jul 31 '15 at 20:23
5

I had the same exact issue, drove me nuts for months and finally fixed it by doing the following. It may be overkill but it worked and that's all that mattered to me lol.

Delete all known wireless network profiles

  1. Open elevated Command Prompt (CRTL+X, Command Prompt(Admin))
  2. Type without quotes "netsh wlan show profiles" and press Enter. This will give you a list.
  3. Type without quotes "netsh wlan delete profile name="ProfileName"" and press Enter.
  4. Repeat #3 for every network that was displayed in your list.
  5. Exit the command prompt

Make sure WLAN AutoConfig service is set to Auto

  1. Open services (Start, type "services" and hit enter.)
  2. Find "WlanSvc(WLAN AutoConfig)" and double click to open it's properties.
  3. Hit the STOP button.
  4. Make sure the "Startup Type" is "Automatic". Somehow mine was set to manual so it never started. Setting it to automatic will start the service at boot.
  5. Close Services

Remove and reinstall all network adapters

  1. Open device manager (CTRL+X, device manager)
  2. Click the "view" menu and select "Show Hidden Devices"
  3. Expand (+) the Network Adapters section
  4. Right-Click every single adapter listed and select "Uninstall" but do NOT select "delete software" if asked.
  5. Restart/Reboot your PC

In theory upon startup your PC will detect and reinstall all currently connected network adapters. And once you re-join your wireless network (you should even have to type in your WPA2 key) you should be asked "Do you want to turn on sharing between PCs and connect to devices?" Answering yes should set the network type to Private and hopefully STICK.

Again this may be overkill but after trying every other "solution" I could find this is the way I could get it to stick. Hope this helps!

  • This is happening for me but I only have a LAN connection. Stupid Windows 10. – kamranicus Oct 28 '15 at 23:40
  • I believe this may have been due to association with a Work (domain) account in Outlook and it enforcing weird group policies on my PC. I removed it so I'll give it some more time and report back. – kamranicus Nov 11 '15 at 0:34
0

I have had the same problem twice. The first time I tried using the Network Reset option that the troubleshooter offers. This worked on the third attempt (so perhaps a bit random).

The next time it happened, I followed the instructions on this page (https://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_web/any-way-to-change-network-from-public-to-private/6ca4a5ff-e692-465f-b6e2-b5abfaeecf43), which run as follows :

The type of the network can changed in the registry:

HKLM\Software\Microsoft\WindowsNT\CurrentVersion\NetworkList\Profiles\

Category:

0 = Public

1 = Private

Change the category tab on any profile that references your network name (eg., TalkTalkxxxxx) to 1.

I tried this (I was desperate) and the network immediately returned to Private and I have had no trouble with this problem since (was about 2 months ago).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.