3

I just got a pair of Bluetooth headphones (specifically, Jaybird Sprint) which supports connection with two different devices at the same time. Quoting the user guide, it says:

The headphones can connect with two devices at most. A mobile phone with HFP profile; and a device with A2DP profiles. If you want to pair two Bluetooth devices, please refer to the following steps.

  1. Firstly, pair the headphones with the Bluetooth adapter
  2. Disconnect the Bluetooth adapter from the iPhone or iPod
  3. Pair and connect the headphones with the mobile phone
  4. Reconnect the Bluetooth adapter, will connect with headphones automatically.

Now, I want to pair it both to my Android phone and a Windows 10 machine. I want to make the phone use the HFP profile, so Windows must connect using A2DP. The problem is that it is connecting always with the best profile the device supports, which is HFP, overriding the Android pairing.

How can I force Windows to pair with A2DP profile to the headphones?

3 Answers 3

6

Windows does not connect with the "best" profile. It connects using whatever you have specified or whatever is first available.

You can specifically set what profiles Windows uses on what device in the Bluetooth settings for that device. How you do that depends on what version of Windows and what Bluetooth stack & software you use. I don't have a Windows 10 machine with me right now so cannot take screenshots on one but the process is vaguely similar.

For example with an Intel Bluetooth driver and default stack under Windows 7, right clicking on the device in Devices and Printers allows you to select what to connect with:

enter image description here

Alternatively, right clicking and selecting Properties allows you to disable or deselect individual profiles and services:

enter image description here

2
  • Good advice! This menu wasn't available on Windows 10, but clicking on "Control" lead to a screen with "Headset Operations" where I was able to disconnect and select only "Stereo Headphones". Then it connected without the microphone option which it seemed to randomly want to use or switch to.
    – jonespm
    Dec 21, 2015 at 14:33
  • 1
    I feel sorry for all the people out there buying bluetooth headsets and having to suffer with the rubbish audio that happens from this bad, default config (the non tech savey) Shame M$.
    – Worthy7
    Jan 22, 2020 at 0:49
1

My Bluetooth headset is Kitsound Arcade, and I have found that on Windows it shows up as two devices, with the Hands-free profile showing as headset and the A2DP profile as a speaker device.

I have used the Sound settings section in the Control Panel to disable the headset device, and keep only the speaker device enabled. This way Windows will be forced to output sound via the A2DP profile and not the headset profile.

0

@qasdfdsaq's answer is great, but on Windows 11 it's hard to find the UI.

  1. Open Control Panel

    enter image description here

  2. Click Hardware and Sound

    enter image description here

  3. Right-click Devices and Printers and select Open in new Window. It's important that you right-click here as left clicking will launch the new settings UI instead.

    enter image description here

    enter image description here

  4. Right-click the device

    enter image description here

  5. Select which services you want

    enter image description here

In my case, I want to disable the communication services of the headphones, as I have a better microphone on my desktop, and hands-free audio is low bandwidth and unpleasant to listen to.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .