2

I just bought Skullcandy "Hesh 2 Wireless" Bluetooth enabled headphones. I connected them to my Windows computer by adding a bluetooth device and everything worked well.

After disconnecting and reconnecting I got a message saying the bluetooth device did not accept a stereo audio connection.

Now everything sounds like crap. I can pair the headphones to my Android phone no problem and the music sounds good.

I've tried removing and re-pairing the device, but it still has crappy sound quality. Any ideas?

It sounds like a pretty generic error that a lot of people get, then people respond with answers like this that say "make sure your device is compatible" http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/cannot-connect-to-imt525-bluetooth-device-on/eceacc8c-3a1c-42c4-9b3d-753dfcea9697

Anyway, my device is on the compatible devices list, and it worked perfectly once

3

Try this:

1) Go to: Control Panel\All Control Panel Items\Devices and Printers

2) Right click the icon of the bluetooth headphones, click 'Properties'

3) Go to the tab Services, uncheck all, leave checked ONLY 'Audio Sink' and 'Remote Control'

This worked for me.

2

Well, all I did was go to my device manager and turn off my bluetooth adapter. Reboot. Turn it back on, and re-pair the device.

I guess the answer here is just rinse lather and repeat rebooting and resetting adapters until it works.

Update: This happenend to me again a few times this afternoon and I can consistently resolve the problem by turning off the BT adapter and back on. No need to pair the device again.

1

I had the same problem with a Lenovo Yoga 900 with Windows 10. After the initial pairing, Playback Devices only showed Headset for default communication. While there was audio, it wasn't in stereo and sounded bad.

I rebooted my machine, repaired the headphones and now Playback Devices shows Headset Default Communication and Headphones Default Stereo. Headset still sounds bad / not stereo, but headphones now sound better.

enter image description here

  • Can you clarify what you mean by "repaired the headphones"? – fixer1234 May 29 '16 at 16:21
0

I made few steps (beginning from installation). I had bluetooth USB inline for Windows 7 x64.

  1. installed generic software for bluetooth
  2. plugged in usb dongle and waited till Windows installs missing drivers
  3. switched my phones in pair-mode and added device in windows bluetooth manager enter image description here.
  4. right clicked on enter image description here and selected Sounds/Devices. New window opened and I selected first tab. Found my headphones with summary text (hands free) and turned it off.

enter image description here

  1. restarted PC and turned off PC
  2. when Windows reached desktop (with icons) i enabled my headphones (Windows should automatically connect with phones with STEREO). If nothing has changed (but it should happen) try manually enable STEREO in Sounds/Devices window.
0

For me, basically the individual steps people mentioned still left me without a solution.

I went to window+r and type devmgmt.msc.
Uninstall all your bluetooth drivers and audio device drivers.
Restart the computer to reinstall all the stuff. It's working so far.

0

I just had this problem myself where Windows would only connect to my bluetooth earbuds in mono, calling the device "[Device name] Hands-free". I couldn't find a way to enable any sort of stereo, but apparently it did detect that stereo was supported, but just had that as the default. The stereo version was therefore hidden since I was disconnected from it.

So I opened up Sound in Control Panel, right-clicked on the list in the Playback tab, and checked "Show Disconnected Devices". "[Device name] Stereo" then showed up in the list, which I right-clicked and hit "Connect". It then set that as the default device and it works fine now.

-1

I found the resolution by removing the Jabra 75 in the Devices and Printers section. And then reinstalling by searching for bluetooth. It's worked for 2 days perfectly since then.

-1

As another user mentioned, this fixed it for my Sennheiser 4.5. I was not getting any stereo at all until I tried this.

  • Open Sound in Control Panel,
  • Right-clicked on the list in the Playback tab,
  • Checked "Show Disconnected Devices".

[Device name] Stereo then poped up in the list,

which I clicked right and hit Connect.

Then is sets as the default device, and it works fine.

protected by Community Oct 2 at 17:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.