8

Background

My parents have a Gateway lx6810-01 that had 32 bit Windows Vista Home Premium. It has two 4 GB sticks of RAM installed (GSkill F3-10600CL9D-8GBNT), totaling 8 GBs. The RAM came with the machine. The weird thing is that the system says that it had DDR2 RAM, even though it came with DDR3 (click here for system specs).

Regardless, I looked up the user manual of the motherboard and it said that the sticks should be compatible.

Because half the RAM was not addressable, I just installed Windows 7 64 bit Professional.

Problem

When I boot up the system I notice in the resource monitor that only about 3 GBs are available, and 5 GBs are under Hardware Reserved Memory. The system still recognizes the 8 GBs of RAM, but only 3 GBs are usable.

Failed attempted solutions

Side note

I ran CPU-Z and it recognized all my RAM and it seemed to be normal.

I also thought maybe the resource panel was displaying my amount of RAM available incorrectly, but when I ran a Python script that kept allocating memory, I ran out after about 3 GBs.

  1. msconfig

    I first tried running msconfig and checking and unchecking the maximum memory checkbox.

  2. Memory remapping and memory hole in BIOS

    Memory remapping was already enabled, but memory hole was not in the BIOS. I tried every combination of the two being enabled and disabled, but nothing fixed it.

  3. Memory diagnostic

    I ran a memory diagnostic in case something was wrong with the memory, but it said everything was fine.

  4. Bootable Ubuntu USB

    I booted up Ubuntu 14.04 LTS from a USB, to check if the problem was Windows, but the problem still existed.

  5. Rearranged and isolated RAM

    I switched the stick, but nothing changed.

    I tried booting up with each stick in each slot by itself, but for every combination the resource monitor showed that 1 GB was Hardware Reserved Memory and the other 3 GBs were available. This makes me think that for some reason the BIOS only recognizes one of the sticks. But I don't know why.

  6. Manually set RAM speed

    I manually set RAM speed to 800 MHz instead of 'auto', but I was unable boot up after that, and had to remove my CMOS battery to restore the BIOS to its defaults.

  7. Checked memory allocation for hardware devices

    I opened up the device manager and checked to see how memory my device were taking up but nothing was out of the ordinary that would take up more than a few hundred MBs.

The Present

I have no idea what to do anymore. Maybe update the BIOS, but there are not any updates that address this issue.

  • look for a BIOS update. – magicandre1981 Jul 25 '15 at 15:08
  • One more odd way to see things, i only did this one time. In device manager "view by resources" or using "system Info" you can see the actual locked out hard addresses in some alien form :-) well alien to me . And also device manager bring up the properties for a device (like a video card) and looking at the "resources" tab i was able to locate and somewhat figure what and where the ram spaces used by the device were. – Psycogeek Jul 25 '15 at 21:09
  • Thanks @Psycogeek for your comment. The mother board only comes with two slots, and I believe cpu-z was saying that it was in dual configuration. I'll check again later and let you know because Windows 7 is updating right now and I do not want to interrupt it. According to online my cpu specs are here. I installed Windows clean with a bootable usb. I've reset the BIOS already. I've never updated my BIOS before, but I could probably do it. – Vivek Jul 25 '15 at 21:28
  • The problem is that there is not a BIOS update that more recent than my BIOS (6/7/2011) that addresses this issue. Link to BIOS updates. I guess there is the possibility that I have an older BIOS. I'll try running memtest86 first and see what it gives me. I thought windows memory diagnostic tool would perform similarly though. – Vivek Jul 25 '15 at 21:45
  • Also I looked at the device manager "view by resources" already, and it showed the HEX memory address that were allocated, and it was no more than a few hundred MBs. – Vivek Jul 25 '15 at 21:47
3

It's not in the OS, you should be able to set the allocated amount to the igpu, it's usually set on auto by default. Set it in the bios

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.