1

Problem:

I upgraded my monitor from 1680x1050 to 2560x1080. In nvidia-settings the maximum resolution I can set is only 1920x1080, leaving a substantial gap on each side of the monitor. The display looks like this.

Attempted solutions:

I first tried the command xrandr --fb 2560x1080 but it made absolutely no difference.

I then tried adding support for this resolution the following way:

cvt 2560 1080
xrandr --newmode "2560x1080_60.00"  230.00  2560 2720 2992 3424  1080 1083 1093 1120 -hsync +vsync
xrandr --addmode DVI-I-2 2560x1080_60.00

The last command returns the error:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  31
  Current serial number in output stream:  32

I have no idea how to interpret these error codes and nothing useful is showing up on Google.

Further details:

If I boot Windows 7, it detects the monitor's correct resolution and everything works just fine. The monitor's input is HDMI and is connected to a DVI-D dual converter since my 9800 GT graphics card does not support HDMI. I'm running Ubuntu 14.04.2 with NVIDIA binary driver version 340.76.

0

I found that the only way to fix this problem was to upgrade the graphics card. The new card doesn't have to be anything fancy, a GTX 460 worked for me. Nothing else needed to be done after the new card was installed, no driver updates, no xrandr, etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.