3

I pinged google

C:\Users\user>ping 216.58.211.164

Pinging 216.58.211.164 with 32 bytes of data: Reply from 216.58.211.164: bytes=32 time=41ms TTL=128

Now I want to try blocking that IP

So I created a rule..
Here are my profile settings

FW-1

Below you see the rule I created in an attempt to stop myself being able to ping that IP

FW-2

And here are screenshots showing the rule

FW-3

FW-4

FW-5

FW-6

FW-7

FW-8

Then I ping and it isn't blocked

enter image description here

Notice from the screenshots that I have chosen all protocols so it should include ICMP.

1
  • it seems maybe if you create a rule that blocks all, and then (test it, ping, get general failure) then edit it to block just the IP, then it works.. Though that then gives a question of why it doesn't work when I make a rule from scratch setting the IP
    – barlop
    Commented Jul 25, 2015 at 21:11

1 Answer 1

3

Possible Issues

1. Select Any Local IP Address

Unde Scope (in your last screenshot), change "Local IP Address":

  • From: "These IP Addresses" (0.0.0.0)
  • To "Any IP Address"

Firewall isn't necessarily "blocking traffic from B", it's "blocking traffic between A and B".

Where A represents your local IP addresses (since multiple IPs can bind to the same box) and B is the remote address. The sure fire way to block any traffic between your machine to the remote one is to just block all IPs from your local box.

2. Block all connections by default

Windows by default allows all outgoing connections. You need to:

  1. Go to Advanced settings of firewall
  2. Then, on the right side panel, click properties
  3. Turn on all tabs (Private/Domain/Public) for Outbound connections to block.

Be warned that it disables ALL outgoing connections, and you need to set up outgoing rules after that for any program you want that allowed to go out.

3
  • -1 Windows by default has outgoing connections as a blacklist and that is fine. I want to allow all except particular ones and I want to add rules for those. I do not want to disable all outgoing like a whitelist, and I shouldn't need to.
    – barlop
    Commented Jul 25, 2015 at 21:09
  • Ahh, I see what you want now. Then change radio-button on the last of your screenshots Local IP address from These IP addresses: 0.0.0.0 to Any IP addresses
    – Alex
    Commented Jul 25, 2015 at 21:42
  • +1 well spotted, I didn't realize the win7 firewall didn't really interpret 0.0.0.0 for local interface as Any. So yeah, changing to Any IP address worked. (or my local ip but better 'any'), works nicely and as I wanted.
    – barlop
    Commented Jul 25, 2015 at 21:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .