1

I am using Arch Linux and LXDE.

I have downloaded Firefox and moved it over to: /opt/firefox (e.g., mv firefox /opt/firefox).

Next, I created symbolic link to the user/bin folder: ln -s /opt/firefox/firefox /usr/bin/firefox

When I type in 'firefox' in terminal it launches 2 Firefox windows instead of just one?

Can someone shed some light on why this is happening?

EDIT: Deleted my firefox folder in /opt and symbolic link in /usr/bin and reinstalled with pacman -S firefox and it still launches 2 windows.

Any idea why this is happening?

  • What's your PATH variable show? Also why didn't you just use pacman -S firefox? – txtechhelp Jul 26 '15 at 1:04
  • How do I show the path variable? Does pacman -S firefox download the 64bit version or just the standard 32bit? echo $PATH shows me /usr/local/sbin:/usr/local/bin:/usr/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl – peter_jackson Jul 26 '15 at 1:06
  • Your $PATH variable is what I meant, sorry, you showed it though :) Doesn't show any 'odd' signs so it might be a misconfiguration elsewhere (LXDE maybe?) .. but pacman will download whatever build you're on, so if your using a 64 bit kernel, it will download the 64 bit version. – txtechhelp Jul 26 '15 at 1:14
  • Ok, I just deleted my firefox folder in /opt and the symbolic link in /usr/bin. Installed it with pacman -S firefox and it still launches 2 windows. – peter_jackson Jul 26 '15 at 1:35
0

I just reset Firefox and removed all settings in about:config and extensions, it seems to be back to normal now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.