I was trying to get a clean Windows installation on my hard drive, but am running into some issues. I get to the part where I need to select which hard drive I want to install Windows on. I have 2 harddrives, but both give this error:

We couldn't create a new partition or locate an existing one. For more information, see the Setup log files.

Extra info:

  • Trying to install Windows 8.1
  • The computer had Windows 8.1 installed before that too
  • I'm installing through an USB drive with MBR partition scheme
  • Screenshot of the error message
  • My BIOS settings: 1, 2, 3
  • I'm unable to copy or upload my Setup log files (since no OS) but I seem to be getting the exact same ones as here

Things I have tried:

  • Cleaning the DISKPART
  • Formatting the drives before attempting to install Windows
  • Deleting and re-adding the drives
  • Deleting and attempting to install on unallocated space
  • Changing the boot order in the BIOS between Harddrive and USB
  • Changing the SATA mode in the BIOS between AHCI and IDE
  • Changing the EFI mode in the BIOS
  • Disabling USB Legacy Boot mode and re-enabling it again
  • Resetting the PC through the advanced Repair options, however this would corrupt the USB drive and result in this error
  • Plugging out one of the hard drives so there was only one to install to
  • Unplugging the USB, however it wouldn't let me continue the installation or even get to the first step without the USB.
  • Fixing the MBR
  • Tried Windows 7
  • Resetting the BIOS to default Factory settings

None of these solutions worked.

  • What boot order's have you tried ?
    – clhy
    Commented Jul 26, 2015 at 21:58
  • GPT or MBR. This error is caused by a mismatch, often caused, by people using Legacy Boot when its not appropriate.
    – Ramhound
    Commented Jul 26, 2015 at 22:09
  • @The_IT_Guy_You_Don't_Like Tried putting USB first and also Harddisk first. Commented Jul 26, 2015 at 22:17
  • @Ramhound so what are you suggesting? Should I make my USB drive GPT format? Commented Jul 26, 2015 at 22:17
  • @PraxisAshelin, did you try press F10 on this screen to run DISKPART & clean the disk ?
    – clhy
    Commented Jul 27, 2015 at 18:41

3 Answers 3


Apparently my specific BIOS version simply did not allow OS installation through USB:

Serial ATA AHCI BIOS, Version iSrc 1.20E
Copyright (c) 2003-2008 Intel Corporation
**This version supports only Hard Disk and CDROM disks.**
Please wait. This will take few seconds.

This would appear for about 0,5 sec during the boot sequence.

I found an old Windows 7 CDRom and it's installing without issues now.


I had the same error installing windows 2012 server R2 in a Dell R210 II. My machine didn't give me a message saying it wouldn't support USB, but I tried practically everything that the OP did to no success. I checked the log %WINDIR%\Panther\setuperr.log and had the message:

Error [0x06069e] IBS GetMachineInfo:Couldn't find boot disk on this BIOS-based computer

I came across a webpage that said the windows installation had problems because it was using USB3.0 and I should try an older USB. I did that too and it didn't work, but it got me in the right track. I booted a CD with grub and booted the USB from there, finally it worked. Here's what I did once I got GRUB loaded:

c # to access the command line
root (hd1,0) # hd1 is the USB stick
chainloader +1

This fooled the windows installer, because I was no longer booting from the USB, I was booting from a CD instead, even though the installer was loaded from the USB. I hope this helps other people.

  • 2
    lol, apparently someone is so upset about this issue that they came here and downvoted all answers..... smh
    – msb
    Commented Sep 18, 2018 at 0:54
  • 1
    Oh well, guess I can at least upvote them all to counteract it..
    – mwfearnley
    Commented Dec 7, 2021 at 11:48

I had the same problem until I used USB 2.0 drive which worked... I used 3.0 before and tried everything without luck. USB 2.0 FIXED this problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .