12

The Google privacy message is incredibly annoying - when I edit all options and set them all to Off (although I doubt this makes any difference!) and accept the review, the same message comes back the following day. What am I doing wrong?

I'm using Windows 7 with Firefox as my browser.

Stupid Google

  • 1
    Are you signed in to Google? Do you have cookies enabled? – gronostaj Jul 27 '15 at 9:18
  • @gronostaj - Before I logged onto SE, I wasn't signed into Google so I guess that's why I received the message? At home, I don't sign into Google, my cookies are always enabled. So the only way to remove the message is that the user must log into Google? – Joseph Jul 27 '15 at 9:27
  • 3
    Do you have your browser set to automatically clear all cookies on exit? It shouldn't be showing up multiple times unless you clear your cookies:) – Adam Woś Jul 27 '15 at 11:30
  • 1
    Right. Then, signing in (though that'd also be cleared by automated cookie clearing), using google.com, or AdBlock will all be good solutions if you don't like seeing this multiple times :) – Adam Woś Jul 27 '15 at 11:35
  • 11
    @AdamWoś "Privacy reminder: In order to prevent this message from appearing, please decrease your privacy so Google can track you better." – user20574 Jul 27 '15 at 12:10
15

There are few solutions that comes to mind:

  • Sign in.

    This should probably stop the reminder from appearing.

  • Use Google.com instead of Google.co.uk

    It seems that Google.com doesn't show the reminder, but Google.co.uk does. You may have to click "Use Google.com" link after visiting google.com, otherwise they will redirect you automatically. (note that this may not work if you're actually in UK)

  • Use AdBlock

    AdBlock can block elements by CSS selectors. The reminder has CSS class _vGg, so adding this rule to AdBlock should hide it:

    ##._vGg
    

    (they may change the class at any point and the rule will stop working)

  • Use Stylish or userscripts

    Similar class-based approach would work with other methods of altering websites. With userscripts you could even use some heuristics to make it survive CSS class change, but it's a bit more advanced and I won't go into details.

  • Signing in and using AdBlock works! I am based in the UK so your second option didn't work but atleast now I should be able to avoid this message on my home computer. Thank you very much buddy! – Joseph Jul 27 '15 at 9:56
  • 7
    You can use google.com/ncr to always get google.com (ncr = "no country redirect"), but your results will not be UK-specific then. – Adam Woś Jul 27 '15 at 11:36
  • Why doesn't google.com show the reminder? Is it because it redirects to the US location where privacy laws are weaker than European ones so no need to ask the user before tracking him/her? – Daniel Mar 28 '16 at 12:39
5

This is most likely a problem with either:

  • Your Google User is not signed-in
  • Your Browser is set to clear your cache and cookies on exit or restart of your program or computer

To remedy cache and cookies issue:

  1. visit the options menu (Button with 3 horizontal lines on it) located on the top right of the default Firefox installation template
  2. click on the Privacy tab on the right side
  3. Under the History header, and be sure to choose "Remember History"
  4. Restart program to test the remedy

If that doesn't work, check to see if you have an Addon in your browser that is causing this issue. Addons are in the same "Options" area you were in when you edited the Privacy tab.

If neither solution works, try checking to see if there is an outside source, (*third party programs like CClearner and Advance System Care) that will clear the cache and cookies upon your exit from your browser. Be sure to check their capabilities before checking on any other possible issues.

  • +1, Many thanks for describing how to store cookies. – Joseph Jul 28 '15 at 9:54
  • I'm not signed in and I haven't closed my browser in weeks. Yet every once in a while I'm asked to review my privacy settings. I wouldn't be surprised if Google was forced to show this to European users every time it changes a bit in its privacy policies. – Daniel Jul 29 '16 at 18:00
5

If this promo is annoying to you and appears repeatedly, make sure your browser is not set up to automatically and regularly clear cookies. If it is and you'd rather keep it that way, you'll need to use any of the workarounds posted by gronostaj.

  • 1
    There, removed the comment about the comment. It is a valid direct answer to "the same message comes back the following day. What am I doing wrong?" (though I'm not implying this cookie setting is wrong, only that it's making the thing reappear) – Adam Woś Jul 27 '15 at 16:12
  • +1, thanks for mentioning a method with cookies. – Joseph Jul 28 '15 at 9:53
  • 1
    Some people want their cookies blocked, especially from Google. – Florian F Jan 4 '16 at 17:38
2

Re Google's security reminders: I tried setting my homepage to Google.com, but then they just automatically reset me to Google.co.uk, as that is where I am based. Now I have set my Homepage to the full Google.com URL, namely: https://www.google.com/?gfe_rd=cr&ei=8U4BVoy2Es3H8geQ4aP4Cw&gws_rd=cr&fg=1 and it seems to work. Not been redirected back to the UK and no security reminders - yet.

  • You can always use google.com/ncr or, once you're redirected from google.com to google.co.uk, you can click "Use google.com" at the bottom right, and this will also be remembered (albeit in a cookie). – Adam Woś Jan 21 '16 at 10:24
  • Only solution so far that lets me delete cookies, not being signed in to the google account, and still search with google. If this nonsense continues, I'll use another search engine. – adabyron Feb 6 '17 at 20:52
1

Two alternative methods:

1/ Override the user agent string, specifically for the www.google.co.uk domain. Before Firefox 25, this could be done by adding something like the following to <FIREFOX-PROFILE>\prefs.js:

user_pref("general.useragent.override.www.google.co.uk", "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:3.2) Goanna/20170101 PaleMoon/27.3.0");

In Firefox >= 25, the same can be achieved by installing an Add-on such as UAControl. The user agent string can be any that Google is not able to recognise. Alternatively, don't send the User-Agent request header at all (in UAControl, the block option for a site achieves this).

As well as disappearing the Privacy Reminder nag, this method also has the side-effect of yielding a slightly different Google UI. Noteworthy is the different search results page, with the country, date/time and results refine options down the left side. Personally I prefer this display because it's fewer clicks to refine.

2/ In a similar vein to some of @gronostaj's solutions it should be possible to hide the Privacy Reminder elements with CSS. A simple way without Add-ons would be to create UserContent.css in <FIREFOX-PROFILE>\chrome and add an appropriate style rule to it:

._vGg {display: none !important}

Restart Firefox for the rule to take effect. This method is also subject to the class name changing, and potentially (though unlikely) unintentionally hiding other web sites' content that just so happen to carry the same class name.

See http://kb.mozillazine.org/index.php?title=UserContent.css for more information on UserContent.css.

protected by Community Nov 6 '15 at 23:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.