0

I am using Ubuntu 14.04 desktop computer.

According to my code I mounted my harddrive and then copy a file in it. I also use 2 USB for this copy operation.

Today I got into trouble. Firstly one of my USB's partition table is corrupted. For solving this I formatted my USB Drive. Then it looks OK. But after rebooting, my computer didn't recognize my harddisk under Devices. Although it looks in the output of fdisk -l and lsscsi when I attemped to mount it I'm getting an error.

  • fdisk -l output:

    Disk /dev/sdb: 250.1 GB, 250059350016 bytes
    255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x0c1190ed
    
    Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1   *          63   488392064   244196001    7  HPFS/NTFS/exFAT
    
  • lsscsi output:

    [1:0:0:0] disk ATA KINGSTON SNV425S D100 /dev/sda [4:0:0:0] disk ATA WDC WD2500JD-00G 02.0 /dev/sdb

  • sudo lsblk -f output:

    NAME FSTYPE LABEL MOUNTPOINT sda
    ├─sda1 ext4 / ├─sda2
    └─sda5 swap [SWAP] sdb silicon_medley_raid_member
    └─sdb1

  • sudo mount /dev/sdb1 /media/Disk1 output:

    mount: you must specify the filesystem type

Then I run this command:

  • sudo mount -t silicon_medley_raid_member /dev/sdb1 /media/Disk1 output:

    mount: unknown filesystem type 'silicon_medley_raid_member'

Then tried this way:

  • sudo mount -t ntfs /dev/sdb1 /media/Disk1 output:

    ntfs_mst_post_read_fixup_warn: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument Record 0 has no FILE magic (0x0) Failed to load $MFT: Input/output error Failed to mount '/dev/sdb1': Input/output error NTFS is either inconsistent, or there is a hardware fault, or it's a SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows then reboot into Windows twice. The usage of the /f parameter is very important! If the device is a SoftRAID/FakeRAID then first activate it and mount a different device under the /dev/mapper/ directory, (e.g. /dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation for more details.

My harddisk didn't exist in blkid output also.

I can not figure out what the problem is, I would appreciate if someone gives any suggestion.

  • It seems unlikely that you would want to mount an external USB disc as a RAID member, so maybe it needs re-formatting. Try using the Disks utility: you can examine, format and mount from this using a simple graphical interface. If Disks is insufficient, try GParted. – AFH Jul 27 '15 at 14:22
  • Note the following from your mount attempt: Failed to mount '/dev/sdb1': Input/output error. That suggests failing (or failed) hardware. You might try running a SMART test on the disk. If you think it's OK, consider further output you've reported: In the first case run chkdsk /f on Windows then reboot into Windows twice. The usage of the /f parameter is very important! NTFS problems cannot be fixed in Linux; they must be fixed from Windows! It could also be a cabling problem. – Rod Smith Jul 27 '15 at 16:29
  • Thank you both guys, after formatting the disk, everything is OK now. – Merve Bozo Jul 28 '15 at 6:00

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.