I'm using Debian Jessie with two graphic cards and 3 Monitors. One on the onboard card and two on an internal card. I can select and configure the two monitors on the internal card but can't get to the monitor on the onboard graphics card. Looking at the Xorg.log with my limited abilities to read it, I think both cards are activated and accessible. My Xorg.log (I couldn't paste it here): https://gist.github.com/anonymous/b67736d974f1d5f23a19

Yet I can't configure it with the provided gui tool. But also xrandr does not show the monitor. I read that I could be able to set it up with this program.

Screen 0: minimum 320 x 200, current 3200 x 1080, maximum 8192 x 8192
VGA1 connected 1280x1024+1920+0 (normal left inverted right x axis y axis) 338mm x 270mm
1280x1024     60.02*+  75.02  
1024x768      75.08    70.07    60.00  
832x624       74.55  
800x600       72.19    75.00    60.32    56.25  
640x480       75.00    72.81    66.67    60.00  
720x400       70.08  
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected primary 1920x1080+0+0 (normal left inverted right x axis  y axis) 160mm x 90mm
1920x1080     60.00 +  50.00    59.94* 
1920x1080i    60.00    50.00    59.94  
1600x1200     60.00  
1680x1050     59.88  
1280x1024     60.02  
1440x900      59.90  
1280x960      60.00  
1280x800      59.91  
1280x720      60.00    50.00    59.94  
1024x768      60.00  
800x600       60.32    56.25  
720x576       50.00  
720x480       60.00    59.94  
640x480       60.00    59.94 

2 Answers 2

[ 2.696] (II) RADEON(G0): GPU accel disabled or not working, using shadowfb for KMS`
[ 3.144] (EE) RADEON(G0): drmmode_do_crtc_dpms cannot get last vblank counter`

in your Xorg.log seems to indicate a failure with your Radeon X1600 graphic card.

firmware-linux-nonfree should be installed, providing the needed proprietary firmware for your ATi GPU. If it doesn't solve your problem (3rd screen not shown in XRandR), post a dmesg log.

After this problem is solved, try to run:

xrandr --setprovideroutputsource 1 0

to enable the output. Since it's only temporary, refer to your distribution, display manager or desktop environment documentation to run it automatically each time you start the graphical interface..

  • I installed ´firmware-linux-nonfree´. It did not solve my problem unfortunately. Here is the dmesg and Xorg log again: gist.github.com/anonymous/be7a7d2b63d126f89021
    – steros
    Jul 28, 2015 at 10:32
  • The monitor is definitely working. I just swapped both VGA monitors as a test. And if I read the log right, the card is enabled and output is tested but it does not activate the monitor.
    – steros
    Jul 28, 2015 at 10:43
  • I see nothing wrong in these logs (maybe I missed something?). xrandr still doesn't show the ATi card? What about xrandr --listproviders?
    – piernov
    Jul 28, 2015 at 12:40
  • shows two providers, intel and radeon with each 3 outputs - it feels like it is just not supported?
    – steros
    Jul 28, 2015 at 12:43
  • What does it say exactly? I'm using a similar setup but with a much more recent Radeon card and only 2 screens, in fact I have to do xrandr --setprovideroutputsource 1 0 to enable the Intel one, by default it's only the Radeon which is enabled and this command makes the Radeon card render the graphics for Intel's output.
    – piernov
    Jul 28, 2015 at 12:54

I believe these will show up as two separate X displays (typically 0.0 and 0.1) because they're on separate graphics cards.

Try doing:

DISPLAY=:0.1 xrandr

See also https://wiki.archlinux.org/index.php/Multihead

You can use xinerama, to use both simultaneously, or you can use traditional multi-head (but then you can't move windows between displays).

  • Can't open display :0.1 I tried several combinations.
    – steros
    Jul 28, 2015 at 9:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.