0

Here's the partitioning I've done during Ubuntu install: https://youtu.be/BcRnqqybMIQ

  • installing OS: Ubuntu 14.04 64bit AMD64
  • device: Asus x205ta
  • Ubuntu bootable USB drive created and BOOTIA32.EFI obtained from Internet inserted to /EFI/BOOT/ directory in bootable USB drive.
  • Currently trying to install ubuntu to a 2nd flash drive. My intention is to keep this 2nd flash drive connected to ASUS X205TA at all times and create dual boot system. (Windows 8.1 w/ bing + Ubuntu 14.04)
  • Partitioning during installation is shown in the above video.
  • /dev/sdb is the 2nd flash drive (Sandisk Ultra 32 GB)
  • created three partitions
    1. swap (2 G)
    2. ESP (EFI system partition) (~100 MB)
    3. ext4 space for Ubuntu (remaining space)

Bootloader installed in ESP so that UEFI will recognize it.

After installing this way, ASUS x205ta failed to boot Ubuntu from 2nd drive.

I'm guessing since the UEFI is 32-bit, I should also copy the BOOTIA32.EFI that I used to recognize the first flash drive also into ESP in the second flash drive.

However, I cannot access this partition. It doesn't have any format.

enter image description here

'Disk2' is the 2nd flash drive where Ubuntu is installed. For some reason all the partitions do not have file format. ESP should be the smallest partition among those three partitions but since it doesn't have any file format I can't even access it to copy/paste BOOTIA32.EFI.

How can I get this Ubuntu flash drive bootable?

1

I solved it. sorry for bothering who read this.

To start, the ESP was actually formatted as FAT32. I checked this out with sudo parted -l.

I don't know exactly what the contents of BOOTIA32.EFI are but I was able to copy this file to the ESP. I did this from the live ubuntu which is booted from the 1st flash drive.

From there I could use 'parted', 'mount' commands to access the partitions in the second flash drive. For example, assuming the 2nd flash drive is '/dev/sdb' and the ESP partition is the second one in line, then '/dev/sdb2' would point to ESP.

Then from home directory I could do the following

~$ mkdir usbmount
~$ sudo mount /dev/sdb usbmount/
~$ cd usbmount
~$ sudo mkdir EFI
~$ cd EFI/
~$ sudo mkdir BOOT
~$ sudo cp /cdrom/EFI/BOOT/bootia32.exe ~/usbmount/EFI/BOOT/

actually, I didn't directly copy the original bootia32.efi file to /dev/sdb2 but first copied to local machine and then copied that to usbmount/efi/boot directory (2 steps). This was because for some reason I ran into a permission deny. But I guess if you're lucky 1step copying would work.

reason for creating EFI/BOOT directory in ESP is due to UEFI conventions. I read this here(quite long. related info somewhere in the middle):

After doing this and rebooting with the modified 2nd flash drive, I was able to get GRUB 2 running! Unfortunately it didn't give me a grub menu with entries that would load ubuntu. It just gave me a bash terminal to work with. From here, I referenced this link to actually load ubuntu. And it worked!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.