0

I just changed out an old Linksys WRT54GS wireless router for a TP-Link TL-WR841N wireless router. I immediately flashed the router to use DD-WRT.

Everything went seamlessly except that my Windows 8.1 desktop can no longer see my Brother HL-2270DW network printer. The printer has a reserved DHCP address of 192.168.1.200 on my local network. I can reach the printer's web interface from Google Chrome on my Android device and from my Windows 7 laptop by simply entering the IP address in the browser's address bar. I can print to the printer from my Windows 7 laptop, also.

I cannot connect to the printer in any way from Windows 8.1. I can connect to the Internet through the router on Windows 8.1. I can connect to all other devices on the local network through Windows 8.1.

Both tracert and ping failed (using the known good reserved IP address of 192.168.1.200). Initially they failed with a "Destination host unreachable" error. It appeared there was an "Invalid" entry in the ARP table of the Win 8.1 machine. I added a static ARP entry with the following command:

netsh interface ipv4 add neighbors Ethernet 192.168.1.200 00-1b-a9-12-34-56

Now ping and tracert return timeout errors instead of host unreachable errors.

  • This question appears similar to mine. One solution might address both problems. I think there's enough value in the different wording of the questions to leave them both in place, though. – mwolfe02 Jul 28 '15 at 2:36
  • This answer may solve my problem, but I'm not sure how to change or verify the settings in DD-WRT: serverfault.com/a/131163/25995 – mwolfe02 Sep 13 '15 at 18:10
0

This answer to a related question solves this problem for me as well. The short answer is it appears to be (what I would consider) a bug with DD-WRT's default configuration. By default, DD-WRT does not enable communication between wired clients on a wireless router. This "vlan" setting must be manually set via the following commands:

swconfig dev eth0 set enable_vlan 1
swconfig dev eth0 set apply

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.