5

Update: They fixed the macOS wifi lag on Synergy 1.9.0! https://symless.com/forums/topic/2587-download-synergy-190-to-fix-the-wifi-macos-bug/

I’m using Synergy 1.7.3 and using a Windows 7-Desktop as the server and a Kubuntu-Laptop as client.

My laptop is connected to my router via WLAN and my desktop is connected via cable. I have no idea what to do since it worked fine first, but for a couple of weeks now the mouse and keyboard are unbearably laggy on the client, to the point where I can barely use them.

4

On older versions of Synergy LAN is much better than WLAN for Synergy. If Synergy has to connect via WiFi at any point, you will certainly get lag problems. I was just having this problem and I solved it by connecting an ethernet cable to the two computers (they sit on the same desk). If you go this route you will have to turn off your wifi and double check you connected the Synergy client to the ethernet connection. Once I did this, there is no lag. This would be the solution if you were gaming or needed to cut mouse latency completely.

You are not going to see any difference in latency between different software that shares a mouse and keyboard because they both rely on WIFI in your situation. Seriously consider using an ethernet cable if you can - the alternative would be to use hardware (KVM switch) which is not a better solution.

Edit 5/26/2017:

It appears this bug has been fixed. The lag over WiFi should be corrected according to a Synergy developer. Leave a comment about your experiences.

  • I would like to add that even though I have wifi enabled on my server I was able to improve performance by having synergy directed towards my server's ethernet's IP address and it immediately improved. – tenmiles Aug 16 '16 at 20:04
  • 1
    This has been fixed! We fixed the macOS wifi lag on Synergy 1.9.0! symless.com/forums/topic/… – Nick Bolton May 26 '17 at 10:07
  • @NickBolton Thanks Nick! Appreciate the effort. I've updated my answer to reflect this information. I've suggested people leave comments with their experiences – Kolob Canyon May 26 '17 at 15:21
2

Kolob's answer is entirely correct.

Personal anecdote: I was using Synergy over Wifi and the performance was utterly abysmal. Just random lags, stoppages, clicking on tabs would take seconds to update. Truly terrible. Based on his answer I went and hooked up my machines using hard-wired ethernet and everything became butter.

I post this as an answer because the difference between my setup and the one recommended by Kolob is that I used an actual gateway (I used to use it as my wireless gateway before my ISP provided their own hardware.) With this technique, each machine still gets to connect to the internet via Wifi as normal, but my gateway acts simply as a vehicle for providing a separate subnet. (the "WAN" port is not even plugged in -- but the router is providing DHCP and the subnet) That way, I don't have to worry about disabling any existing network, etc., and both can live together harmoniously.

When configuring Synergy, just make sure you're using the IP addresses of the subnet provided by your gateway rather than your Wifi connection. A simple ipconfig or ifconfig should facilitate determining which IP address you want the client to use (the server will be bound to all its IP addresses, so you don't have to worry about it).

On a Mac, make sure to go to System Preferences > Network and then click the little gear icon on the bottom of the list of network interfaces you have (i.e. Wifi, LAN, etc.) and click "Set Service Order". Then drag to make sure your actual ISP interface (i.e. Wifi) is ordered above your ethernet (LAN) interface. Otherwise you won't get any internet on your Mac. (didn't have this problem on Windows for whatever reason)

2

I had the same problem just a second ago, I tried all the other fixes (other than Ethernet for my mac).

On the host PC (windows), go to Task Manager (Ctrl+Shift+Esc), then click on the details tab on the top, then search for synergy.exe, synergyd.exe, synergys.exe and then right click on them and under the set priority sub menu choose High.

  • Interesting fix! Does this work for others who are using wifi? – Nick Bolton Mar 3 '17 at 18:01
1

I have also faced a similar problem. In my case client was running on Windows 7 while server was running on Ubuntu 12.04. To resolve this problem kill the synergy server and again start it:

  1. Identify the process number of the running server:

    ps -ax | grep synergy
    

    The output of the above command will look like

    29102 ?        Ssl    0:02 synergys
    29233 pts/0    S+     0:00 grep --color=auto synergy
    
  2. Kill the synergy server:

    sudo kill -9 29102
    
  3. Restart the synergy server:

    synergys
    

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.