No idea how this happened. plasmashell was crashing after consuming 6gb memory and I'd tried removing ~/.cache. Shortly after all plasmashell would do is start my desktop background with a wallpaper but wouldn't give me any taskbar and I couldn't bring up a menu by right clicking the desktop.

Restarting it or rebooting the whole machine didn't help.


jozxyqk's answer is correct, but it is fairly drastic. It will blow away all of your toolbar customizations, app favorites , etc.

Depending on the cause of this issue in your case, you may be able to fix it by editing your plasma-org.kde.plasma.desktop-appletsrc file and then performing

kquitapp plasmashell && kstart plasmashell

One cause I've run into is the buggy multimonitor functionality sometimes "losing" the taskbar from my laptop screen after I've connected to an external monitor and later disconnected (this was in plasma 5.5 or 5.6, I think). In this scenario, I've found the problem to be the lastScreen setting in the taskbar configuration. To fix this, find the section of text in plasma-org.kde.plasma.desktop-appletsrc that looks like:


(Some of these lines may vary in your configuration. In mine, this section was only a dozen lines down in the file, but I have no idea how much that may vary.)

Setting lastscreen=0 fixed the problem for me. I assume that 0 represents my laptop screen, and 1 is the external monitor.

If in doubt, you can always perform the procedure in jozxyqk's answer, and compare the newly generated plasma-org.kde.plasma.desktop-appletsrc with your saved plasma-org.kde.plasma.desktop-appletsrc.bak before restoring an edited version of your saved copy.

  • Heh, one of those "Wish I had read that first" things :) – Dmitri DB Jul 14 '16 at 20:27
  • Thank you very much, how did you find it? – Pavel Dec 27 '16 at 3:12
  • 1
    @Pavel, if I remember correctly, I found it like this: jozxyqk's answer lead me to the correct file. I saved my file and used his solution, and then compared the new file to my old file. lastScreen seemed a likely candidate so I tried it (replacing my old file with a change to that one thing). – EricS Jan 1 '17 at 0:52
  • In my case, the "kquitapp plasmashell" command produced an error ("Quitting application plasmashell failed. Error reported was: org.freedesktop.DBus.Error.NoReply : Did not receive a reply ....") and I had to kill the plasmashell. – Daddy32 Jan 31 '18 at 8:34
  • 1
    @WorseDoughnut: Alt-Ctrl-F2? – EricS Aug 19 '18 at 4:25

Update: Please see EricS's answer first as you may be able to avoid losing your KDE config.

I ended up removing random config files with the name plasma in them. The one that worked was:

cd ~/.config
mv plasma-org.kde.plasma.desktop-appletsrc \

Then restart plasmashell:

kbuildsycoca5 && kquitapp plasmashell && kstart plasmashell
  • This just happened to me as well. Your solution worked, but I had to chown ~/.cache/sycoca5 to my username first. – Geremy Aug 3 '15 at 0:52
  • I could kiss you!!! – DrorCohen Jun 2 '16 at 1:32
  • A million thank yous for this: your fix helped. I had completely run out of ideas. – lightonphiri Jul 20 '16 at 12:34

I have also found this condition occurring when a plasma-org.kde.plasma.desktop-appletsrc.lock file is left in the ~/.config directory. Removing the lock file cleared the problem immediately.


In my case with KDE 5.8.8 removing the following two config files helped:

rm ~/.config/plasma-org.kde.plasma.desktop-appletsrc
rm ~/.config/plasmashellrc

Then starting KDE again.

For some reason, default widgets like taskbar were not configured on initial setup during some upgrades etc.


I know this post is really really old but today also still this bug not solved by KDE. It happens lot of time but cofig again and again is really annoying & irritating but today I found the quickest & easiest solution for it. Just hit ALT+F2 and type "ksysguard" , Open it then find "Kwin_x11" right click on it then click on send signal and final step is click on Interrupt(INT) within 5-10 Seconds display will it turn black and you will return in login section as soon as you login. Panel(s), Wallpaper etc... everything back on track..... I mean whatever configuration is in use you brought it back as it was exactly before this problem appeared. I am not sure about the application you are using that session will recover or not. Because this happen with me while doing System update so please anyone use this method and your application session restore or not update give us an update if in case station not been restore and somehow you restored it let us know how you did that thanks in advance "help for help"

My first post on superuser.


Edit plasma-appletsrc and delete this section.

[PlasmaViews][Panel 46][Horizontal1600]

Then reboot.

  • 1
    Your instructions are very unclear. I'm not sure people could implement your solution based on what you've written. Can you be more explicit? – fixer1234 Nov 3 '16 at 3:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.