0

I have bought and used many external hard drives, such as the traditional ones like Seagate Backup Plus 2TB, or the Samsung SSD T1 with 512GB, and all of them can be repartitioned using Mac's Disk Utility as ExFAT, and be immediately used as an external hard drive by both the Mac and the PC (using Windows 7).

But this time I bought a Samsung EVO 850 internal SSD drive, and using a case (such as the Anker or the Inateck), it is said to be able to function as a USB 3.0 SSD external drive, but after I partition it as ExFAT, when I copy files in, the Mac keep on asking for password and saying I can copy, but the files won't be visible. When the drive is plugged into a different Mac, I cannot read those files either.

So how to make this internal SSD drive work just like any other external SSD drive?

  • 1
    I don't really know what's going on, but I very seriously doubt that the underlying storage technology has anything to do with it. Forget the fact that it's a SSD, and instead just treat it as a data storage device. What else might be different between the two cases? – a CVn Jul 28 '15 at 7:52
  • I think it might not be the cases... I can use any one of them and they behave the same: that it is different from any other external hard drives – 太極者無極而生 Jul 28 '15 at 8:06
  • Perhaps you've accidentally enabled FileVault on the drive? If you right-click the drive on the desktop, does it come up with an option like Decrypt [diskname]? – James P Jul 28 '15 at 9:47
  • Those devices have additional features within their firmware. Did you enable this feature before putting it into enclosure? Additional have you tried installing the Samsung software to check if the feature is enabled? It sounds like you have the device encryption turned on, which has a password, since it keeps asking for one. – Ramhound Jul 28 '15 at 11:03
  • I was also thinking that, since these drives might be used as the OS boot drive, could there be additional security or encryption? Perhaps it does have some encryption turned on by default and I need to install the Samsung software to turn it off. I didn't touch that CD-ROM that came with the SSD drive as my Macbook doesn't have any DVD drive – 太極者無極而生 Jul 28 '15 at 23:06
1

The solution seems to be this: when you highlight the drive to format in Disk Utility on a Mac, you have to make sure you highlight the whole drive, instead of just the primary partition.

I think the first couple of times, I only highlighted the primary partition and formatted it as ExFAT, and the encryption is still in effect. But afterwards, I highlighted the whole drive and formatted it, and it stopped asking me for password and behave just like any other ordinary hard drive.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.