I tried to install the new Visual Studio 2015 Community Edition but unfortunately without success because the installation gets stuck on creating a system restore point.

What I did to solve the problem:

  • checked if enough space on disk
  • started installation as administrator
  • adjusted the maximum disk space used for system protection (4GB)

Do you know other possible solutions I could try to solve my problme? Ty

  • Are you able to create a restoration point manually currently?
    – Ramhound
    Jul 28, 2015 at 11:18
  • @Ramhound I never created a restoration point manually. But is there any way to get over this step and continue with the installation?
    – CMS
    Jul 28, 2015 at 11:25
  • I am asking if you can create a restoration point in order to rule out several dozen reasons connected to the inability to do so. When you answer my simple but important question I will be continue my research into your problem.
    – Ramhound
    Jul 28, 2015 at 11:52
  • @Ramhound i tried it and yes I am able to create a restoration point manually
    – CMS
    Jul 28, 2015 at 11:56
  • I have not installed VS in awhile. The restoration creation process is before/after the installation process begins/ends? Can you verify the hash of the .ISO your using is correct?
    – Ramhound
    Jul 28, 2015 at 11:58

5 Answers 5


I had the same problem during installation VS2015 on Windows 10.

I solved the problem by killing the svchost.exe process that blocked the installation:

  1. Go to the Task Manager details tab
  2. Find vs_community.exe
  3. Open the Analyze wait chain,
  4. Check svchost.exe and kill it.

It will stop creating the system restore point, but will resume the installation.

  • 4
    In my case it was csc.exe Sep 3, 2015 at 22:40
  • 1
    Same solution works when installing Visual Studio 2013 Update 5. Just look for VS2015.5.exe instead. Sep 6, 2015 at 18:49
  • In my case it was csc.exe too, ty!
    – Ricardo
    Sep 20, 2015 at 16:41
  • 1
    In my case it was dllhost.exe :)
    – Predelnik
    Dec 1, 2015 at 9:24
  • 1
    I experienced a different scenario. Analyze Wait Chain only revealed two vs_community.exe with different PIDs (1240 & 6421). Ordered Details by PID and found the nearest PID svchost.exe (1280), ended that and it continued installation
    – Pierre
    Aug 22, 2016 at 8:53

Try to disable any antivirus running on your machine. It worked for me.


The current version of AVG Free antivirus is incompatible with Microsoft Visual Studio 2015.

  1. It does not allow Visual Studio to be installed on the computer. It gets stuck at "Creating restore point". Visual Studio installs perfectly when AVG is turned off.

  2. Any code compiled in "Release" mode targeting x86 platform/environment (in project properties) does not compile. It compiles successfully when AVG is turned off.

I posted the issues in AVG support forum but no one responded.


I had same problem.
I'm using 2 Anti-Viruses AVG Internet Security, Avast Internet Security.
I tried to stop AVG Firewall and stop Avast until shutdown.
And It worked. Installation success


For Windows 8 the above is almost right. Analyze chain yielded no svchost.exe. However, if you're only running the installer just look for the svchost.exe that is the biggest memory hog, cross your fingers, kill it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.