56

I want to disable Bluetooth on my laptop running Windows 10 Pro x64, but I have a problem: the option to do so is missing even though I know that it was previously available.

Here is the Bluetooth settings pages should look like on Windows 10:

Bluetooth Settings Page - Windows 10

Here is how it looks for me:

Bluetooth Settings Page - Windows 10

As you can see, I am missing the switch to turn it on or off? Why is it missing? I know that just yesterday, it was available and I turned it off. What can I do to fix it?

  • Laptops usually have a keyboard shortcut to enable/disable bluetooth? – MrWhite Jul 28 '15 at 22:28
  • I am not sure in this, but You can try to press the Win key + X, there is an option for it in the windows that pops up. Tell me if this works or not. – Divin3 Jul 28 '15 at 22:46
  • If the Bluetooth driver was just installed or upgraded, the toggle may not show up until you restart the computer. Once you restart, you will find the toggle in the Settings app. You will also find a new toggle button for Bluetooth at the bottom section of the Action Center (may need to Expand that section to see it). So, in the tone of Roy from The IT Crowd, have you tried turning it off and on again? – ADTC May 8 '16 at 11:36
  • I just freshly installed Windows 10 here, and I think this happened to me because I set my WiFi as metered network. I'll look further into it. – Gui Imamura Jul 4 '17 at 3:01
40
  1. Bring up the start menu. Search for "Device Manager".

  2. Go to "View" and click "Show hidden devices"

  3. In Device Manager, expand Bluetooth.

  4. Right click on Bluetooth Generic Adapter and update the driver.

  5. Restart.

Worked for me. :)

  • 13
    There was no Bluetooth in Device Manager to expand – Matthew Lock Jul 23 '16 at 2:50
  • 4
    It says Windows has determined the driver software for your device is up to date. So, alas, this is not the solution. – James M Mar 21 '17 at 15:33
  • 1
    this did not work for me – thoggy Apr 7 '18 at 13:39
  • Windows said it was up to date, however disabling it and re-enabling it worked. It now functions normally. – mjp May 8 '18 at 16:49
  • 1
    Didn't have a "generic adapter" under Bluetooth, but I did have an "Intel(R) Wireless Bluetooth(R)". I updated the drivers for it, also updated Windows while I was at it, then restarted the computer. Everything worked afterwards. – ArtOfWarfare Jul 9 '18 at 0:05
10

I found a solution that seems to work for me.

1.) Uninstall everything that is Bluetooth-related that is listed in Programs & Features.

2.) Uninstall all Bluetooth-related drivers listed in the Device Manager.

3.) Restart the computer. Bluetooth will be reinstalled, and you can reinstall the programs that you removed from Programs & Features.

The problem is mainly because the drivers provided by vendor does not support windows 10 (this happens if you have migrated from windows 7 or windows 8.1). Reinstalling the bluetooth driver (Programs and Features)only would solve the problem.

  • workd for me on win10, exept that I needed to reboot with the ethernet cable connected (wifi was also broken) – JinSnow Apr 20 at 18:26
5

There are all kinds of problems that can cause this, judging by the amount of solutions I've found. Only one worked for me, so I'm adding this here.

I have a Dell XPS 13 9350 and had to do a reset of the BIOS to fix this. No idea what had changed in the BIOS, but multiple restarts didn't help. After resetting the BIOS to Factory settings (not BIOS Defaults, but I didn't try that), Bluetooth worked as expected again.

  • I had a similar problem on a Dell XPS 15 9560 running the latest Windows 10 preview build with current BIOS & drivers. Multiple restarts didn't help, but changing a seemingly unrelated BIOS setting did (I don't want to mention which one to avoid people cargo culting and just saving the BIOS settings might have worked). After that, the option to disable or enable bluetooth reappeared. – James L Nov 24 '17 at 21:15
  • This worked for me on my MSI GT72VR after a recent windows update. – user3495690 Jun 17 '18 at 14:26
  • This was the only solution that worked for me, also on a Dell XPS 13 9370, i.e. go into BIOS, click "restore settings" and then choose Factory settings. Thanks! – Justin Dec 17 '18 at 8:51
  • This worked for me on a Dell XPS 15, but with the Bios Defaults option. I didn't try the other one as I remembered wrong which one you used. :-D – Dan Pettersson Jan 4 at 12:52
4
  1. Go to Network Connections (type Network Connections into the windows search box, choose "View Network Connections")
  2. Right click on your Bluetooth connection.
  3. Choose disable.
  • At the time that this was an issue for me, I tried this and it did not work. – DavidB Aug 13 '15 at 20:07
  • This appears to only disable bluetooth networks, not the bluetooth adapter itself. – stevemidgley Jan 13 '17 at 15:13
4

Most of the solutions here did not work for me. In my case, my laptop had an Intel Wireless Bluetooth driver. After searching for that, I ended up on Intel's website and downloaded the latest version of the driver. After running the executable and doing a "Complete" install, I restarted my machine and the Bluetooth switch returned to the Settings window.

Note, when I tried updating that same driver earlier through the Device Manager interface, Windows incorrectly told me that my Driver was the best and most up-to-date one already.

  • "Note, when I tried updating that same driver earlier through the Device Manager interface, Windows incorrectly told me that my Driver was the best and most up-to-date one already." - I have never seen the Device Manager accurately report that a driver update is available. All it ever says is that you're running the most up-to-date driver. – DavidB Nov 2 '17 at 0:48
3

I found an easy fix that worked for me - turn off windows 10 fast-startup and then turn off your computer then on again. steps:

  • WinKey -> type to search "Power & sleep settings"
  • "additional power settings"
  • "choose what the power buttons do"
  • "change settings that are currently unavailable"
  • untick "Turn on fast startup"
  • Save changes
  • turn off computer then turn it on
  • 1
    It's been a while since I posted this question, but I think I had tried that without success when I was having this problem. Still though, if it worked for you, it's a good suggestion. Thanks for posting! – DavidB Apr 20 '18 at 2:41
  • 2
    I'm shocked but this worked for me! Hoping it might fix some other wi-fi issues I've been having too – Ben Thomson Jun 18 '18 at 1:33
2

I just went into network connections and selected bluetooth then above that in the options selected disable and that disabled it.

  • 4
    improve your answer and ill upvote. – Francisco Tapia Aug 7 '15 at 21:10
0

Another thing to consider, if you have a spare WLAN adapter / card for your laptop. You can also try to exchange the cards. Check if the Bluetooth afterwards works. Strangly for me it did with my old adapter as soon as I booted into Windows again. So I disabled Bluetooth, turned of the computer and switched my other one (previously not working) back in and it started immediately working again. The switch for turning on Bluetooth was showing up again and it was also listed in the device manager.

I tried most of the above listed suggestions but none did help or brought it back to life. However the quick swap did some magic. This seems to be a bug within Windows 10 because I'm pretty sure this wasn't a connection issue since the WLAN worked flawlessly. Another thing to note is that a driver update of either the WLAN or Bluetooth broke the Bluetooth functionality.

So if you have a second one lying around and don't want to tinker with software methods which probably won't work if you your adapter disappeared in the device manager try this out. It might be a quicker fix.

Maybe it is also enough to remove the adapter startup Windows, shut it down and put in the adapter again. I haven't tried that, but this might also be worth a shot.

PS.: Both adapters are Intel 7620 AC and 1030 N.

0

This might just be a variation of Joe's suggestion of turning off fast startup, but this worked for me:

  1. Shut down computer
  2. Unplug computer
  3. Keep her unplugged for several minutes (MINUTES, NOT seconds) to allow her to cool off and think about what she's done and to really suffer for the extreme shame she's feeling over the massive inconvenience that her behavior has caused the household
  4. Plug in computer
  5. Turn on computer
  6. Computer will regret her actions and will hopefully have turned bluetooth back on. Forgive the computer and live a fulfilling together until the arrival of the next inevitable problem she wants to give you.

protected by Community Aug 30 '15 at 21:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.