84

I want to disable Bluetooth on my laptop running Windows 10 Pro x64, but I have a problem: the option to do so is missing even though I know that it was previously available.

Here is the Bluetooth settings pages should look like on Windows 10:

Bluetooth Settings Page - Windows 10

Here is how it looks for me:

Bluetooth Settings Page - Windows 10

As you can see, I am missing the switch to turn it on or off? Why is it missing? I know that just yesterday, it was available and I turned it off. What can I do to fix it?

5
  • Laptops usually have a keyboard shortcut to enable/disable bluetooth? – MrWhite Jul 28 '15 at 22:28
  • I am not sure in this, but You can try to press the Win key + X, there is an option for it in the windows that pops up. Tell me if this works or not. – Divin3 Jul 28 '15 at 22:46
  • If the Bluetooth driver was just installed or upgraded, the toggle may not show up until you restart the computer. Once you restart, you will find the toggle in the Settings app. You will also find a new toggle button for Bluetooth at the bottom section of the Action Center (may need to Expand that section to see it). So, in the tone of Roy from The IT Crowd, have you tried turning it off and on again? – ADTC May 8 '16 at 11:36
  • I just freshly installed Windows 10 here, and I think this happened to me because I set my WiFi as metered network. I'll look further into it. – Gui Imamura Jul 4 '17 at 3:01
  • No luck with any answers. Tried this as well but my hardware is dell wireless 1705 bluetooth and it seems like that itself is a problem – zar Oct 2 '20 at 18:08

12 Answers 12

53
  1. Bring up the start menu. Search for "Device Manager".

  2. Go to "View" and click "Show hidden devices"

  3. In Device Manager, expand Bluetooth.

  4. Right click on Bluetooth Generic Adapter and update the driver.

  5. Restart.

Worked for me. :)

9
  • 21
    There was no Bluetooth in Device Manager to expand – Matthew Lock Jul 23 '16 at 2:50
  • 6
    It says Windows has determined the driver software for your device is up to date. So, alas, this is not the solution. – James M Mar 21 '17 at 15:33
  • 2
    this did not work for me – theodore hogberg Apr 7 '18 at 13:39
  • 3
    Windows said it was up to date, however disabling it and re-enabling it worked. It now functions normally. – mjp May 8 '18 at 16:49
  • 1
    Didn't have a "generic adapter" under Bluetooth, but I did have an "Intel(R) Wireless Bluetooth(R)". I updated the drivers for it, also updated Windows while I was at it, then restarted the computer. Everything worked afterwards. – ArtOfWarfare Jul 9 '18 at 0:05
14

I found a solution that seems to work for me.

1.) Uninstall everything that is Bluetooth-related that is listed in Programs & Features.

2.) Uninstall all Bluetooth-related drivers listed in the Device Manager.

3.) Restart the computer. Bluetooth will be reinstalled, and you can reinstall the programs that you removed from Programs & Features.

The problem is mainly because the drivers provided by vendor does not support windows 10 (this happens if you have migrated from windows 7 or windows 8.1). Reinstalling the bluetooth driver (Programs and Features)only would solve the problem.

2
  • workd for me on win10, exept that I needed to reboot with the ethernet cable connected (wifi was also broken) – JinSnow Apr 20 '19 at 18:26
  • restarting the computer is mandatory. Not just turning it off and then on. Restart command is needed – BabaNew Jun 12 '19 at 7:30
14

I found an easy fix that worked for me - turn off windows 10 fast-startup and then turn off your computer then on again. steps:

  • WinKey -> type to search "Power & sleep settings"
  • "additional power settings"
  • "choose what the power buttons do"
  • "change settings that are currently unavailable"
  • untick "Turn on fast startup"
  • Save changes
  • turn off computer then turn it on
3
  • 1
    It's been a while since I posted this question, but I think I had tried that without success when I was having this problem. Still though, if it worked for you, it's a good suggestion. Thanks for posting! – DaveTheMinion Apr 20 '18 at 2:41
  • 3
    I'm shocked but this worked for me! Hoping it might fix some other wi-fi issues I've been having too – Ben Thomson Jun 18 '18 at 1:33
  • This worked for me. I tried to install drivers but no luck. This one worked uncheck "Turn on fast startup". Thanks. – TanuAD May 30 '20 at 6:15
9

There are all kinds of problems that can cause this, judging by the amount of solutions I've found. Only one worked for me, so I'm adding this here.

I have a Dell XPS 13 9350 and had to do a reset of the BIOS to fix this. No idea what had changed in the BIOS, but multiple restarts didn't help. After resetting the BIOS to Factory settings (not BIOS Defaults, but I didn't try that), Bluetooth worked as expected again.

4
  • I had a similar problem on a Dell XPS 15 9560 running the latest Windows 10 preview build with current BIOS & drivers. Multiple restarts didn't help, but changing a seemingly unrelated BIOS setting did (I don't want to mention which one to avoid people cargo culting and just saving the BIOS settings might have worked). After that, the option to disable or enable bluetooth reappeared. – James Lupolt Nov 24 '17 at 21:15
  • This worked for me on my MSI GT72VR after a recent windows update. – user3495690 Jun 17 '18 at 14:26
  • This was the only solution that worked for me, also on a Dell XPS 13 9370, i.e. go into BIOS, click "restore settings" and then choose Factory settings. Thanks! – Justin Dec 17 '18 at 8:51
  • This worked for me on a Dell XPS 15, but with the Bios Defaults option. I didn't try the other one as I remembered wrong which one you used. :-D – Dan Pettersson Jan 4 '19 at 12:52
6

Most of the solutions here did not work for me. In my case, my laptop had an Intel Wireless Bluetooth driver. After searching for that, I ended up on Intel's website and downloaded the latest version of the driver. After running the executable and doing a "Complete" install, I restarted my machine and the Bluetooth switch returned to the Settings window.

Note, when I tried updating that same driver earlier through the Device Manager interface, Windows incorrectly told me that my Driver was the best and most up-to-date one already.

2
  • "Note, when I tried updating that same driver earlier through the Device Manager interface, Windows incorrectly told me that my Driver was the best and most up-to-date one already." - I have never seen the Device Manager accurately report that a driver update is available. All it ever says is that you're running the most up-to-date driver. – DaveTheMinion Nov 2 '17 at 0:48
  • thank you so much this worked for me! – Neeta Apr 25 at 11:26
5

If you find yourself in this situation:

enter image description here

Is because: damn Microsoft f**** up the BIOS with some update.

I had to open a ticket with the Intel support because uninstalling / repairing / installing the right driver wasn't working. The solution was to enter in the BIOS and setup the default setting. After reinstall the Bluetooth was back:

enter image description here

That guy saved my day.

2
  • This happened on my Asus and the above fix corrected the issue – JDandChips Nov 26 '20 at 14:32
  • Thanks a lot, this worked for me ;) – NaseemH Mar 24 at 9:09
4
  1. Go to Network Connections (type Network Connections into the windows search box, choose "View Network Connections")
  2. Right click on your Bluetooth connection.
  3. Choose disable.
3
  • At the time that this was an issue for me, I tried this and it did not work. – DaveTheMinion Aug 13 '15 at 20:07
  • This appears to only disable bluetooth networks, not the bluetooth adapter itself. – stevemidgley Jan 13 '17 at 15:13
  • This worked for me except I had to disable and re-enable everything in Network Connections window. – garenyondem Jun 18 '20 at 16:57
2

I just went into network connections and selected bluetooth then above that in the options selected disable and that disabled it.

1
  • 4
    improve your answer and ill upvote. – Francisco Tapia Aug 7 '15 at 21:10
0

Another thing to consider, if you have a spare WLAN adapter / card for your laptop. You can also try to exchange the cards. Check if the Bluetooth afterwards works. Strangly for me it did with my old adapter as soon as I booted into Windows again. So I disabled Bluetooth, turned of the computer and switched my other one (previously not working) back in and it started immediately working again. The switch for turning on Bluetooth was showing up again and it was also listed in the device manager.

I tried most of the above listed suggestions but none did help or brought it back to life. However the quick swap did some magic. This seems to be a bug within Windows 10 because I'm pretty sure this wasn't a connection issue since the WLAN worked flawlessly. Another thing to note is that a driver update of either the WLAN or Bluetooth broke the Bluetooth functionality.

So if you have a second one lying around and don't want to tinker with software methods which probably won't work if you your adapter disappeared in the device manager try this out. It might be a quicker fix.

Maybe it is also enough to remove the adapter startup Windows, shut it down and put in the adapter again. I haven't tried that, but this might also be worth a shot.

PS.: Both adapters are Intel 7620 AC and 1030 N.

2
  • The only thing that works for me when this happens is just straight up unplugging the machine. I wonder if your solution reduces to that since you probably unplugged it while you were making the swap. – PerpetualStudent Aug 13 '20 at 14:34
  • @PerpetualStudent That is a good question, I never had this issue again. But I think I unplugged the laptop as well, which did not work. So I decided to replace the card. – thex Aug 18 '20 at 6:46
0

I had to do a system restore because I had previously installed the "ScpToolkit", which is for connecting a Playstation 3 Dualshock controller to your computer via bluetooth. It seemed to screw up the bluetooth on my Acer laptop completely.

I also tried uninstalling everything related to Bluetooth in Device manager and then reinstalling some of the Bluetooth drivers found on Acer website for my laptop but those didn't do anything. Bluetooth still wasn't showing up on Device Manager (even though I turned on View --> Show hidden devices).

0

I had tried everything and I thought it will never work but finally got it to work!

I had installed a USB bluetooth dongle as well after the fact which I have lost and it seemed a mashup.

I noticed I had another issue too that when I go into device manager, I was constantly refreshing after every little while. I figured I should perhaps fix that first and following up, it indeed was connected with bluetooth driver. When I uninstalled the bluetooth device, the refreshing stopped.

When I scanned for new devices, the bluetooth driver automatically got installed and refreshing problem appeared as well.

I had the show hidden devices option enabled from view menu. There were several items listed under blutooth (previously connected device). I uninstalled them all but they will come back when scan for new devices.

I repeated uninstalled them several times but on 3rd time, the refreshing stopped and out of no where I got this screen as well.

enter image description here

I checked all checkboxes and pressed Ok.

Now I got back to windows settings and I can see the bluetooth switch (enable/disable) option! I connected Bluetooth speak and it works!

So it's definitely he driver. Previously I did installed the new driver (find service tag of Dell system and took latest available driver from dell) but that alone didn't fix the issue.

Another suggestion I can give you is if you can somehow force this dialog (posted above) to come and selected `Allow bluetooth devices to find this PC' (this was the deselected when the dialog came up), that seems to apply the proper settings too perhaps.

Update

The problem returned after reboot. I searched "bluetooth" in installed programs for drivers and I had two different ones installed as listed bow. Uninstalling the WIDCOMM Bluetooth Software and rebooting fixed the issue for good. (First I let it stay and uninstalled the intel one but that didn't fix the problem).

enter image description here

0

If you're running a VM (virtual machine) client such as VMWare, VirtualBox (vBox), or Virtual PC, check to see if it's stealing the bluetooth device and disable that.

For instance, I have a VMWare client running on my work laptop. Today I discovered I was unable to use my bluetooth headset for a Zoom call on the laptop. The Bluetooth button in the Action Center was gone, and the Windows 10 bluetooth settings for my headset said simply, "Bluetooth is turned off".

After looking around for a while, I realized the VMWare client window was stealing the USB bluetooth adapter from the host (the laptop), as shown below. Once I unchecked that, all bluetooth features on the laptop came back:

enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.