15

I've installed Windows 10 official release (not the preview) from Windows 7 Ultimate SP1 and I've some problems with the language. My OS is in French but all my modern-ui apps (weather, store, calendar,...) are in English. I've W10 Professional and I precise that when I had W7, I had to set default language to French after the installation (this was an english version of Windows). Have you some ideas ?

16

I've solved my problem by putting in the languages settings the French language at the top. After some restarts all my modern ui apps are in French.

  • 3
    It looks like orders matters (i.e. first language not supported by application, take second, if not supported take third...) – tinamou Sep 8 '15 at 13:33
  • 1
    Very helpful answer. Who would have guessed that a presented Languages choice of English (Canada) would be invalid? My Windows 10 Pro (Version: 1607, OS Build: 14393.351) Modern Apps defaulted to the next language on the list, so had to make that English (United States) to get an english "skin" for the Modern Apps. – Petr V Nov 7 '16 at 12:22
10

Registered just to post this, hope it helps others who got fustrated with it as well.

Under Control Panel > Language > Advanced Settings > Override for Windows display language

Defaults follows your language setup, you can choose to select what language you wan't to show here.

2

It's a late answer, but when I had the same problem I solved it very quickly and easily. I live in Germany and love my OS to be in English. In order to achieve a full English OS, including apps, and a German keyboard layout I went into my locale settings (Settings => Time & Language => Region & Language) and first off moved English (which was set to override the OS language) to the top. Then I clicked on English, clicked on Options and directly clicked on Add a keyboard and selected the German keyboard layout. After that was set I removed the US keyboard layout and then had Windows 10 displaying in English, including all of the apps, with a German keyboard layout.

I hope this answer alone might help or would give you some options to look after.

0

My problem was that I did not set my default language as the one that I wanted Windows 10 apps to be in.

For Windows 10 users:

Settings > Time & language > Region & language > Click the language that you want it to be default > Set as default

Then after you restart the Windows 10 app, it should use the default language setting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.