1

I recently plugged in an external hard drive of mine and noticed that it doesn't show up on the list of drives in Computer. I opened Disk Management (dskmgmt.msc) to check and it said that 'You must initialize a disk before logical manager can access it':

I didn't allow it to initialize and clicked 'Cancel'.

The drive shows up as Unknown, Not Initialized and Unallocated in Disk Management:

I ran GetDataBack for NTFS to attempt to recover my files and this is the screenshot of the log ~1 1/2 hours after it was first run:

It seems to me from the GetDataBack log that it is not reading any files at all. The log shows messages all looking like: Error 1117 in HD130: duringReadLba: LBA=43569984, CHS=-lx-lx-l, Cnt=64

Details: This is on Windows 7. Drive is formatted as NTFS. The drive is a 1 TB WD Elements, HDD model no: WD10JMVW, not often used and connected (only around 30 minutes every 2 - 3 days, just to move files from my main HD) and not more than a year old. I don't hear any clicking sound coming from the drive. The drive's status light works properly when it is being accessed by GetDataBack. It also shows up in Device Manager as 'working properly' and by its proper name (WD Elements 1048 USB Device). I tried accessing the drive in two different computers, and the same thing happens in Explorer, Disk Management and Device Manager.

WD Data Lifeguard is unable to read the SMART data. Here is the result when I attempt to run a 'quick test' with it:

Test Option: QUICK TEST
Model Number: WD Elements 1048
Unit Serial Number: [redacted]
Firmware Number: 1022
Capacity: 1000.20 GB
SMART Status: Not Available
Test Result: FAIL
Test Error Code: 08-Too many bad sectors detected.
Test Time: 22:31:42, July 29, 2015

Screenshot of Data Lifeguard messages:

HDD Guardian (a GUI for Smartmontools' smartctl) however, can read the SMART data:

SMART data according to HDD Guardian

Is there anything else I could do to attempt to recover as many of the files in the hard drive as possible?


EDIT: I opened up the enclosure to attempt to retrieve the HDD inside it and insert it as an internal drive to my computer as per suggestion from comments. However, it appears that I am not able to do this as it appears that the USB interface is connected to the HDD and can not be removed (there appears to be no SATA interface).

screenshot 1 of HDD as described above

screenshot 2 of HDD as described above

screenshot 3 of HDD as described above

  • 1
    First thing to do in any data recovery case is to make a full copy of the drive (clone, image, etc.) before attempting anything else. In this case it looks like the drive is hitting a bad sector and causing the USB controller to hang. Best way to recover data in these cases is take the drive out of the USB enclosure. – qasdfdsaq Jul 29 '15 at 10:08
  • @qasdfdsaq You reckon I should stop the GetDataBack recovery, take it out of the enclosure and insert it as an internal drive to my computer to get an image of it? GetDataBack still currently saying the same error message. – galacticninja Jul 29 '15 at 10:17
  • Yes, that's what I would do. – qasdfdsaq Jul 29 '15 at 10:19
  • 1117 likely to be I/O device error. agrees with the above, I don't think your getting anywhere. – Psycogeek Jul 29 '15 at 10:42
  • @qasdfdsaq I have removed the HDD from its enclosure but I seem to be unable to insert the HDD as an internal drive to my computer (there seems to be no SATA interface) . Please see my edit to the question. – galacticninja Jul 30 '15 at 7:38
1

From the description and images (great on both), it appears there are either a lot of bad sectors or a head is not reading.

As @qasdfdsaq commented, it's possible the USB is hung up on one bad sector making the drive inaccessible.

First you should clone the drive with ddrescue or similar if you want to work on it yourself. That prevents anything you try being irreversible and making things worse. There are plenty tutorials available for it and it's fairly simple to use. Since it's a WD Elements (not My Book or My Passport), you should take the drive out of the enclosure first. With a My Book or My Passport, you don't have that option since they drive is encrypted and/or has onboard USB (instead of SATA connection).
Update at bottom.

You can attempt software recovery from the clone. Maybe you'll just be able to read it and copy most/all of your data. Or you'll need to try a data recovery utility again.

If you can't make a clone, or have problems after that, your best option is to contact a professional data recovery service. Most offer free evaluations so you can find out the likelihood of recovery and what it would cost before going forward.

UPDATE
You have an onboard USB connection onboard with this model, since I guess this is a portable Elements drive instead of a desktop one, so you're stuck with USB. Due to that, it will likely hang on bad sectors even with ddrescue but you can try. The real solution is to swap the USB board out for its SATA counterpart (if I knew the board number, I could tell what boards are compatible). The ROM chip at the U12 position would also have to be swapped over to the donor board. From there, then you use cloning software. It will not be encrypted since it's a WD Elements, so you should be able to access the data on the clone. If it were a My Passport, you'd need a My Book USB/SATA bridge with the same controller (Initio, Symwave, JM, etc.) to decrypt the clone.

If this is too ambitious of a fix for you (finding parts and swapping chips), but you want a better result than you can get from USB, you will need to contact a data recovery company. Contact a few, see which you are comfortable with. This would likely be on the low end of their services (unless there is some other issue not apparent here), and most offer free evaluations so you know what it would cost before you go forward.

| improve this answer | |
  • Know of a good Windows equivalent for ddrescue? I have removed the HDD from its enclosure but I seem to be unable to insert the HDD as an internal drive to my computer (there seems to be no SATA interface) . Please see my edit to the question. – galacticninja Jul 30 '15 at 9:29
  • @galacticninja You could boot from a Linux live CD (instead of Windows, using BIOS boot priority), then use ddrescue. ubuntu-rescue-remix.org I see your update and the photos with the onboard USB. I updated my answer above. – Datarecovery.com MK Jul 30 '15 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.