Trying to update my German Windows 8.1. Professional to Windows 10, it fails after about half an hour with the (German) error message:

enter image description here

We couldn't install Windows 10

We've set your PC back to the way it was just before you started installing Windows 10.

0x80070004 - 0x3000D
The installation failed in the FIRST_BOOT phase with an error during MIGRATE_DATA operation

I've looked into the Windows Event log (and found nothing meaningful) and also did a Google search which leads to this chinese post which suggests a solution that I do not understand (after translating).

My question:

Any hints on how to resolve the error that occurs during the installation?

Update 1:

The chinese post Google-translated to English suggests:

We recommend that you set for automatic windows update. If the download is complete, in which tips off network may try to install during the installation stage.

If that does not work, please wait for a new installation after the 29th win10 official release!

Update 2:

I did again try to install:

  1. Install all Windows 8.1 updates through Windows Update.
  2. Reboot just to be sure.
  3. Check again if any missing Windows Updates (none).
  4. Try to upgrade again to Windows 10.

Unfortunately one hour later the upgrade was canceled again with the same error.

  • 1
    Can you provide that solution. Perhaps we can understand what the solution is given our greater knowledge as a whole.
    – Ramhound
    Commented Jul 29, 2015 at 11:26
  • 1
    The 0x80070004 error occurred with the Windows 8.1 upgrade when the User folder was redirected from C:\ or the user profile was corrupt. May be something similar here. Commented Jul 29, 2015 at 11:55
  • 1
    @DavidMarshall - Good Catch! I suspect that is indeed the problem. You need to move your user profile back to the system partition if you want to perform the upgrade.
    – Ramhound
    Commented Jul 29, 2015 at 11:58
  • 1
    There is some stuff here that may or may not help answers.microsoft.com/en-us/insider/wiki/…. I've uninstalled anti-virus, stopped all startup programs in task manager and I'm burining the iso to a disc, rather than mounting it, and turned off wifi/lan. If it works I'll let everybody know.
    – rashleighp
    Commented Aug 2, 2015 at 7:18
  • 1
    @UweKeim: corrected, bad copy-paste.
    – bwDraco
    Commented Feb 15, 2017 at 6:08

2 Answers 2


Finally I've got a working solution, based on this tweet:

  1. Disable all antivirus tools (I've had no external tools beside the Windows-built-in, so nothing to do here for me).
  2. Follow the instructions in the KB article.

The KB article shows a script to run, after installing a MSI.

I've had to adjust the script since the Windows user group account administrators is named administratoren in my German Windows 8.1.

After running the adjusted script (for about 10-20 minutes), I've launched the Windows 10 setup again and it ran k.

I'm now writing this from my Windows 10 and seem to be happy.


Since the Microsoft KB article seems to be removed, I've opened the Google Cache version of the KB article and copying the relevant information here.

From the KB article:

Error 0x80070005 in Windows Update when you try to install updates


Error code 0x80070005 is also known as "ACCESS DENIED." It usually occurs when you lack file or registry permissions that are required to install the update. (Because file or registry permissions may be changed by malware, we recommend that you scan for malware after you repair the permissions.)

To resolve the issue, make sure that you are logged on as an administrator, and then install the updates again. If the problem continues, use the SubInACL tool to repair file and registry permissions. To do this, follow these steps:

  1. Download the SubInACL tool (Mirror), and install it to the default path that is offered by the installer. The default path will be one of the following, depending on your version of Windows:

    • %ProgramFiles%\Windows Resource Kits\Tools (32-bit versions of Windows)
    • %ProgramFiles(x86)%\Windows Resource Kits\Tools (64-bit versions of Windows)
  2. Start Notepad, and then copy and paste the following commands:

     @echo off
     echo Determine whether we are on an 32 or 64 bit machine
     if "%PROCESSOR_ARCHITECTURE%"=="x86" if "%PROCESSOR_ARCHITEW6432%"=="" goto x86
     set ProgramFilesPath=%ProgramFiles(x86)%
     goto startResetting
     set ProgramFilesPath=%ProgramFiles%
     if exist "%ProgramFilesPath%\Windows Resource Kits\Tools\subinacl.exe" goto filesExist
     echo ***ERROR*** - Could not find file %ProgramFilesPath%\Windows Resource Kits\Tools\subinacl.exe. Double-check that SubInAcl is correctly installed and re-run this script.
     goto END
     pushd "%ProgramFilesPath%\Windows Resource Kits\Tools"
     subinacl.exe /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f  /grant=system=f
     subinacl.exe /subkeyreg HKEY_CURRENT_USER /grant=administrators=f  /grant=system=f
     subinacl.exe /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f  /grant=system=f
     subinacl.exe /subdirectories %windir% /grant=administrators=f /grant=system=f
     echo FINISHED.
     echo Press any key to exit . . .
     pause >NUL
  3. Save the file as Reset.cmd. (Super User note: English download, German download)

  4. Right-click the Reset.cmd file in File Explorer (in Windows 8.1 and Windows 8) or Windows Explorer (in Windows 7 and Windows Vista), and then click Run as administrator. In Windows XP, double-click the file in Windows Explorer.

  5. Wait until the execution finishes, and then try to install the update again.

Note If you receive errors when you run SubInAcl, see the following Microsoft blog: Notes about a couple of possible issues while using the SubInAcl tool.

  • Did you get any Failed - Access denied during subinacl commands? I'm getting some, and I was wondering whether it was normal or not Commented Jul 30, 2015 at 6:22
  • 1
    However, unfortunately this fix didn't work for me. Still getting the error as above. Commented Jul 30, 2015 at 10:25
  • 1
    The sudden removal of the KB makes me worried. MS may have pulled it because it was giving bad advice for users who are upgrading to Windows 10. Commented Aug 3, 2015 at 18:57
  • 2
    At the least, it may result in an insecure configuration. While changes to %windir% may get overwritten, changes to the registry may remain. Worse, there may be a bad interaction with eMMC systems (ie, tablets). Would like some official advice or a more specific fix. Commented Aug 3, 2015 at 19:02
  • 1
    What worked for me twice is much simpler. Just removing the password from the main Administrator account. Doing so the upgrade didn't fail. Commented Feb 17, 2016 at 14:08

Today I stumbled upon this issue while upgrading from Windows 7 to Windows 10 This is how I resolved it:

  1. I restarted the setup again with "Run as Administrator". Although my logged in account was Admin only, I still did this step.

  2. Last time I chosen 'Keep and Apps and Personal Data" option. This time I chosen "Delete everything". This wiped out my application installations and associated data, but it did installed Windows 10 successfully.

I hope this could help to someone coming here searching for this issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .