4

After having had Flash installed and blocked with NoScript for the last few years (except on a enable-per-use base), I have recently -- a month or so ago -- grown tired of the frequent security issues and uninstalled Adobe Flash for good on all my computers.

Much to my annoyance, even though I have NoScript running (which still has "block Flash" checked), some sites, in particular one major tool vendor, still manage to present me with Flash.

(No, these sites are not white listed. The technical reason why it works is that they're not embedding their Flash movies but placing them directly in a <FRAME> or <IFRAME>. Disallowing both<FRAME> and <IFRAME> in NoScript certainly "fixes" the issue, but this is a global setting that may negatively impact not few websites in an a-priori unpredictable way, so I would prefer not to do that.)

Now of course, having no Flash installed, I couldn't bother any less than whether a website uses Flash.

If, well, if Firefox didn't pop its unknown-MIME-type dialog every single time:

You have chosen to open:
xKDJGXxkljjw
Type: application/x-shockwave-flash (24,9 KB)

Open with...
Save File
[x] Always do that without asking

Well, no. I have not chosen to open that file. I don't want to open it (neither in an external program nor in Firefox), and I don't want to save it to disk either. I don't even want Firefox to waste my bandwidth downloading it.

I can click "Cancel", which of course works fine (it does nothing, which is just what I want), but next time I am presented the same dialog again.

Is there a way I can tell this stubborn piece of software to simply ignore a particular MIME type and do nothing at all? Such as an about:config for permanently ignoring a certain type?

I would be comfortable with editing MimeTypes.rdf if that was of any avail, but to my knowledge the only options it offers are "system default", "open in browser", "open with program", and "save", too. There seems to be no "do nothing" option.

| improve this question | | | | |
1

You might try installing this "NOP.exe"program, http://joenord.com/apps/nop/, and tell Firefox to use that for application/x-shockwave-flash programs. I've just had the same message from Firefox and found your question while searching for what to do about it. I haven't tried this yet; I expect to reinstall Flash when I hear its latest security problem is fixed.

| improve this answer | | | | |
  • What a brilliant idea. I wish I had thought of it myself, years ago. I can only give you one up vote though :-) – Rohit Gupta Oct 18 '15 at 5:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.