0

I have a Sharkoon SATA QuickPort with USB 3.0 connection (http://www.sharkoon.com/?q=en/content/sata-quickport-xt-usb30-v2). Whenever I connect this device to a USB 3.0 port on my computer with a hard drive in the QuickPort. The hard drive isn't recognized in Windows.

When I try to reboot my computer, it hangs on the shutting down screen unless I power off the QuickPort (then my computer shuts down immediately). When it starts booting I put the power back on on the QuickPort, and the boot process hangs too. When I again power it off my computer boots up instantly.

When I connect the same QuickPort a USB 2.0 port on the motherboard, none of this happens and I can happily do whatever I want (mainly creating backup images of customer hard drives).

When I plug in a regular USB 3.0 stick into that same USB 3.0 port on my motherboard I can use it just fine, so I don't think there is a driver problem.

It has always been like this since I'm using Windows 8 so I'm guessing it's some OS setting.

  • No; It actually sounds like a hardware incompatibility. – Ramhound Jul 29 '15 at 12:59
  • Incompatibility between hardware and OS, hardware <> motherboard,...? – Maarten Ureel Jul 29 '15 at 13:02
  • My response is based on the following assumptions. 1) The problem always existed. 2) You have not tried other HDDs with the Sharkoon 3) You understand the device itself is a USB 2.0 device. The product you linked to is a USB 2.0 only device. – Ramhound Jul 29 '15 at 13:13
  • 1), The problem has always existed on Windows 8, not on Windows 7 on the exact same computer (dual boot). 2) I have tried numerous hard drives in the docking station, always same result 3) Sorry, wrong link, updated question. – Maarten Ureel Jul 29 '15 at 13:37
  • How many USB devices do you have installed at any given time? – Ramhound Jul 29 '15 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.