5

When running SQL Server Management Studio 2014, the Connect Object Explorer window always starts off-screen:

Broken SQL

I've tried the ALT+SPACE+M trick from this SU question and that works to move it, but when I close or cancel out of the Connect Object Explorer window and re-open it, it's back there again. The SHIFT on close doesn't work for this.

I have a dual monitor setup where one monitor is portrait and one monitor is landscape. The problem only happens when I open SSMS on my landscape monitor, which is the default.

Is there a way to force it to open center-screen?

  • You could move the program to the other monitor, then hold SHIFT and click the close X button. Holding shift will (should) force the computer to remember where the window was when it shut and will become its new default start up position. Or, move it to the screen you want, but don't have it maximised, manually resize it so it's near enough maximised, then shift-close – Dave Jul 29 '15 at 14:33
  • The shift close doesn't work. – Brandon Jul 29 '15 at 14:42
  • Windows 7 x64 (text to hit the length requirement) – Brandon Jul 29 '15 at 14:48
  • 2
    I know this is kind of old, but Microsoft has simply chose not to fix this problem. connect.microsoft.com/SQLServer/feedback/details/724909/… – user610049 Jun 24 '16 at 20:03
1

Generally speaking; Change the resolution on the monitor, or change the virtual position of your monitors to move the window. Move it to where you can see everything then use it or close with with something other than "Cancel" this can change the grid location it loads at.

I have had problems with other applications that required a change in registry to change that default location, but you can change the location normally by moving then closing the window and reopening it.

  • I have to admit I wasn't hopeful about the virtual position of the monitors. In this image: i.imgur.com/4APzXbG.png, the left side was what I had, the right side was what I changed it to and it worked. Kind of frustrating that it works like that but it makes sense. Any tips for what part of the registry I'm hacking to fix the position for SSMS 2014? :) – Brandon Jul 29 '15 at 14:51
  • I would love to help with that, but I dont have SSMS installed on a system and I can not locate any reference material for the entry. Best I could come up with was somewhere around, HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\MSSQL.1\MSSQLServer – El Turner Jul 29 '15 at 15:06
  • Ah okay, I was hoping maybe you knew off the top of your head. I'll mark your answer because it's the cause of the problem. If I find a solution in the registry I'll add it. Thanks for the help. – Brandon Jul 29 '15 at 15:13
  • Maybe in a few more years Ill know. – El Turner Jul 29 '15 at 15:19
0

Win-Shift-left/right arrow is a shortcut key to move the active window to the next/previous monitor; this might be more "sticky" than a regular move.

On that note, I have one program that always opens its dialog box on the "main display" (per Screen Resolution dialog), regardless of which display its main window is on. You could switch your main display to whichever one it currently isn't and see if it still happens. Note that switching your main display will move your taskbar to that display, but you can then manually move it back, which will not redefine your main display.
Note that this second option might just switch the problem to happen on your portrait monitor instead.

  • I should have added that Win+Shift+Direction and Win+Direction don't work for me either. – Brandon Jul 29 '15 at 16:41
0

I suggest everybody who encounters this issue opens a support ticket with Microsoft. Because this is unbelievable! It's been an issue for as long as I can remember, for 20 years no less. How hard can it be to detect that one rectangle (window) is NOT inside other rectangle(s) (screens), and move the former so that it is? It's easy, very easy.

For example, this never happens on macOS -- at least some part of the window always sticks out.

If people don't confront Microsoft about this directly, chances are this is going to be an issue for the next 20 years as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.