3

I've installed Windows 10. Then I tried to install the driver for my nvidia card (gtx 750) but it failed. At first restart the resolution became really high (1920x1080) so it seemed like the driver was installed successfully. Then suddenly black screen. I've restarted the computer and it went back to 1024x768 and I can't change it. I've tried reinstalling the driver, even tried different versions but with no success.

  • You indicated it failed. This means there is a log file, which indicates the failure, we need the failure and the log file. Based on what you describe it sounds like you installed the faulty Windows 10 Nvidia driver by accident. Be sure you have the fixed version before you attempt to install it again. – Ramhound Jul 29 '15 at 14:57
  • Sorry, forgot to provide that. I'll do that ASAP. – Peter Lenkefi Jul 29 '15 at 14:58
  • This is a long-standing problem and is not specific to Windows 10. There are plenty of solutions on Google, most of which include using a driver cleaner and reinstalling the driver: google.co.uk/search?q=nvidia+driver+black+screen – qasdfdsaq Jul 29 '15 at 15:00
  • 1
    downloading the driver for windows 10 from nvidia worked for me. – Journeyman Geek Jul 29 '15 at 15:02
  • Could you provide the link where you downloaded it from? – Peter Lenkefi Jul 29 '15 at 15:24
2

So what I did was removed everything nvidia related from my computer and I've let Windows find a driver for me. That worked and good enough for me.

  • 1
    To clarify this answer: Search for 'Device Manager' underneath the 'Search' bar and click to open it. Once the Device Manager window opens, click the drop down arrow next to 'Display Adapaters' or 'Other Devices' to find your graphics card. Right click the item and choose 'Update Driver Software' and choose the first option - 'Have Windows search online'. – Ben Sampica Jul 31 '15 at 20:16
0

@Peter your solution didn't work for me (W10 insisted on that I already had the most updated drivers...)

Following @Journeyman's advice I downloaded the drivers from nvidia official web page. It's important to add here that after installing and rebooting I had to create a personalized resolution:

right click > nvidia control panel > Screen > change resolution > personalize...> create personalized resolution

There I chose 1280x1024 at 60Hz for 32 bits AND Under Synchronization I chose GTF (the "automatic" didn't work)

Now I have this other resolution rather than the 1024x768

protected by Mokubai Jul 30 '15 at 10:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.