6

After upgrading to Windows 10, I see my LastName and FirstName on the lock screen. Is there a way to change this? On Windows 8.1 there was just my nickname and email address (maybe there were my first name and last name, but not displayed so large as they are now).

I mean the name and surname parameters specified in my Microsoft account.

Another question: I prefer the format FirstName LastName, not vice versa.

Is there any way to change this as well?

Apart from Lock Screen I see it on the Start Menu.

  • I see my first name, then last name. Is it in the correct order on your Microsoft account? If you want, you could switch to a local account instead. – MC10 Jul 29 '15 at 18:20
  • As far as I can tell, name is only displayed on the login screen. The lockscreen just has time and date with a user-customizable background image. – goblinbox Jul 30 '15 at 0:48
2

First, either right-click the start icon and click 'Run' or press WinKey+R to open the run prompt.

Next, type 'NETPLWIZ' and click OK.

Click the user account you wish to edit, then click properties.

From this dialog you can then change the Username and the Full Name of the user account.

Relog to apply your changes.

Edit: Looks like as soon as you log back in it is overwritten with your full name from your email address.

To get around this, log into your account at https://account.microsoft.com/.

Click 'Edit Name', and in the Surname input hold the 'Alt' key while typing +202A using the numpad for the + and digits.

If this doesn't work, you probably can't input hex unicode without using a tool such as Unicode Input. Simply repeat the steps but once the Unicode INput dialog displays, enter 202A and click OK.

It won't look like a character has been entered but clicking save will save your account with a blank surname.

  • The full name is stored in the V entry under HKEY_LOCAL_MACHINE\SAM\SAM\Domains\Account\Users\00000XXX. To prevent changes, you could try setting the 00000XXX key to read-only permissions. – XP1 Dec 7 '15 at 4:03
  • @XP1 Fwiw, when I go to HKEY_LOCAL_MACHINE >>> SAM >>> SAM, I've got nothing but the (Default) with (value not set). – ruffin Apr 9 '17 at 18:08
  • @ruffin, that is because you don't have the view permissions for the current user. You need to modify the registry ACL to include your user with read/white permissions applied with inheritance on subchildren. – XP1 Apr 10 '17 at 6:59
  • @ruffin Right click > Permissions... and then restart regedit. – XP1 Apr 10 '17 at 7:06
0

The problem was that my Last Name and First Name were mixed up in my Microsoft account. I fixed that and the problem got resolved.

As this question has ~10k views now, I guess that it's not only me who entered his surname in First Name field. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.