3

After running the Windows 10 Pro upgrade from Windows 8.1 Pro, things appeared ok for a while. Then I ran into some trouble with VPNs -- while connected to the cisco AnyConnect vpn I could not see the rest of the internet, only the remote networks at the other side of the vpn. (While on 8.1, I had split horizon, no trouble.) At this point I made several mistakes:

  • I had not done a full backup before upgrading
  • I did not do a full backup now before trying to fix my vpn trouble
  • I did not record the steps I took trying to get the vpn working as I wished.

The next thing I knew, I'd lost all network access completely. The (wired, not wireless) network adapter showed as "disabled" in the "Network Connections" window. The Enable button tried to do something, but nothing changed. The Diagnose button reported that troubleshooting was unable to automatically fix anything; the details showed this interesting message:

Windows couldn't automatically bind the IP protocol stack to the network adapter

The Properties window of the connection is even weirder; the "Connect using" dropdown that normally shows the hardware name is blank, as is the list of protocols in "This connection uses the following items"; and "Install", "Uninstall" and "Properties" buttons for the protocol list are all grayed out!

screenshot

127.0.0.1 still works. I can ping it and even browse websites on my local IIS.

From here I tried these things:

  • As described here the problem may very well be related to the Cisco AnyConnect vpn client. That link says to revert from 10 to 8.1, remove the client, and re-upgrade. Windows 10 says I can't revert to 8.1 because files were removed.
  • Uninstalling the AnyConnect vpn client (from inside Windows 10).
  • Reinstalling the AnyConnect vpn client (from inside Windows 10).
  • Removing the wired adapter from Device Manager, and letting it be autodetected.
  • Adding a wireless USB adapter. Same no-protocols view of that connection.
  • Removing both adapters in device manager and letting them be redetected after reboot.
  • Running this sequence of netsh commands. And the expanded "nuclear reset" command list here.
  • Absolutely everything here. Of possible interest: wmic nic get Caption reports only this one adapter. Unlike other working machines, there are no miniports, no Teredo tunneling adapters and no ISATAP adapters.

    [00000000] Microsoft Kernel Debug Network Adapter

  • SFC /SCANNOW. "Windows Resource Protection found corrupt files but was unable to fix some of them." CBS.Log reports one file cannot be repaired: Cannot repair member file [l:24{12}]"adcjavas.inc" of Microsoft-Windows-Microsoft-Data-Access-Components-(MDAC)-RDS-CE-JVS. I have trouble believing that's related to this.

  • Another nuclear option, "Reset this PC". The reset failed, for reasons I was unable to determine, but nothing changed.

My next move is to take a full backup of the machine as it is now, then do a full clean install of either Windows 8.1 or Windows 10 onto a wiped drive. I'm hesitant for obvious reasons; I won't lose any important files, but it will set me back quite a bit of time in reinstalling stuff. So this is my last hope.

8
  • If you cannot perform a Refresh/Reset. If you cannot go back to Windows 8.1 because you already ran the cleanup too. You really only have one option and that is to perform a clean install. Have you ran the DISM command, the data the SFC command repairs is compared against the data that the DISM command repairs.
    – Ramhound
    Jul 29, 2015 at 23:09
  • I was not aware of the DISM command. What options should I use? My install source was a USB drive prepared by the download tool. Jul 29, 2015 at 23:23
  • Now running: DISM /online /cleanup-image /restorehalth /source:f:\ . Thanks! Jul 29, 2015 at 23:27
  • Didn't work. The source files could not be found. Use the "Source" option to specifiy the location of the files that are required to restore the feature. Jul 29, 2015 at 23:43
  • In order to solve this problem you will need a Windows 10 .ISO of the same version and language you have currently installed.
    – Ramhound
    Jul 30, 2015 at 0:55

4 Answers 4

1

The Cisco VPN has not yet been updated for Windows 10 and is incompatible with the OS.

Microsoft has shared a KB that should fix this. the KB can be found at https://support.microsoft.com/en-us/kb/3084164

Resolution

To resolve this issue, follow these steps:

Open an administrative Command Prompt window. Run the following commands:

reg delete HKCR\CLSID\{988248f3-a1ad-49bf-9170-676cbbc36ba3} /f

netcfg -v -u dni_dne

NOTE: this requires changing your registry information. Make sure you backup your registry before executing this.

1
  • If this had been available days ago when I needed it, I probably would have marked this as the answer. Sorry. Aug 3, 2015 at 14:52
1

Note :

I also had this problem after upgrading to Win 10 from 8.1 and i figure it out; My mistake was disabling some new services brought with win 10 or services that were disabled on my win 8 installation.

Solution :

Check if the service "NetSetupSvc" is started and set to "manual start" (default) and not disabled.

net start NetSetupSvc

You can also check from the service manager (my system is in french the service is named : "Service Configuration du réseau")

Alternative Solution :

Check the windows logs while you opening the network card properties to track where the problem is coming from ;)

0

I gave up and backed up, then reinstalled, from a burned ISO. Deleted every partition on my SSD drive.

0

I had this same issue. It started happening after an unfortunately timed power outage about an hour after my upgrade to 10. I tried many different things to solve the issue, but i could barely find any evidence that anyone else has had similar problems. In the end I used the Win10 iso to upgrade my OS again (upgrade from win 10 to 10), and it resolved the problem.

2
  • I should have tried that ... sigh Aug 3, 2015 at 14:49
  • it happened to me again on another pc. had nothing to do with vpn clients or whatever. looks like the upgrade doesnt sync/write changes to disk so its all still in memory buffers. if you crash your windows (like installing a bad driver) immediately after the upgrade its corrupt half 8 half 10
    – Any
    Aug 4, 2015 at 6:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.