3

After I upgraded my laptop from Windows 8.1 to Windows 10, my network connectivity was gone because all protocols were unchecked in the adapter settings. When I went to go turn them all back on, I got my network connection back, but I couldn't (and still can't) enable the Multiplexor protocol. When I select it and click 'Ok', a dialog informs me that my selections will cause it to be disabled:

enter image description here

If I click No, it returns me to the "Ethernet Properties" sheet with the multiplexor protocol disabled. If I click Yes, it unchecks the multiplexor protocol and then closes the dialog and property sheet.

The googler wasn't very helpful, here. There are a few threads out there in which users express the same issue, but the support they received was quite useless.

I also tried to do this in PowerShell to see if it would either a) just work, or if it would b) give me a more useful error message.

C:\Users\Benjamin> Get-NetAdapterBinding -InterfaceAlias "Ethernet" -ComponentID ms_implat

Name                           DisplayName                                        ComponentID          Enabled
----                           -----------                                        -----------          -------
Ethernet                       Microsoft Network Adapter Multiplexor Protocol     ms_implat            False


C:\Users\Benjamin> Enable-NetAdapterBinding -InterfaceAlias "Ethernet" -ComponentID ms_implat
C:\Users\Benjamin> Get-NetAdapterBinding -InterfaceAlias "Ethernet" -ComponentID ms_implat

Name                           DisplayName                                        ComponentID          Enabled
----                           -----------                                        -----------          -------
Ethernet                       Microsoft Network Adapter Multiplexor Protocol     ms_implat            False

Turns out that was really too much to hope for.

While reading it did occur to me to make sure the NdisImPlatform service was running, and I made sure using sc.exe:

C:\Users\Benjamin> sc.exe config NdisImPlatform start= demand
[SC] ChangeServiceConfig SUCCESS
C:\Users\Benjamin> sc.exe start NdisImPlatform

SERVICE_NAME: NdisImPlatform
        TYPE               : 1  KERNEL_DRIVER
        STATE              : 4  RUNNING
                                (STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
        WIN32_EXIT_CODE    : 0  (0x0)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0
        PID                : 0
        FLAGS              :

After this, I tried the things I described above again, but to no avail.

Also, ultimately this is yak-shaving in order to get bridged networking to work in VirtualBox, and so I thought I might try to repair the VirtualBox installation (by running the installer again), but that didn't help either.

Anybody know why this is happening in Windows 10 and how I can fix it?

4

Microsoft Network Adapter Multiplexor Protocol should be left unticked. It is only used with NIC Teaming - i.e. where you have two physical network interfaces that are being used in a load balancing or redundant configuration. In that case the two physical NICs have only this binding ticked (all others cleared), and the team adapter has the normal bindings ticked - but not this one.

  • Is it used by Virtual Box? It's been a while since I looked at this, but I remember at the time thinking that bridged networking required it. – Ben Collins May 11 '16 at 22:49
0

What version of Virtual Box are you running - I had the same problems, but decided to upgrade to the newly released version 5 of VirtualBox - which fixed the network adapters not displaying in Bridged mode, but I still have problems getting into the VM - Port 22 & 80 just won't connect inbound.

I can go out of the VM to the internet and can start (and connect to) the machine etc with the VirtualBox program, but I like to run things headless with VirtualBox manager on the command-line. :(

0

Ultimately I never found a way to fix this directly; I installed Virtual Box 5 - which I didn't realize had released until I was looking for a solution to this - and things went back to working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.