In all windowses before 10 I could just pull the taskbar up and I could see which day it is:

enter image description here

But when doing that in Windows 10 it doesn't work:

enter image description here

How can I get my weekday back without having to hover over the clock?

  • You probably can't, not without a third-party app. I'm not sure how a single-click to the clock is more arduous than pulling up the taskbar; same number of clicks. – goblinbox Jul 30 '15 at 0:31
  • I keep the taskbar always this way :) Probably should've mentioned that, I mean I pull up the taskbar after each windows install :P – Gizmo Jul 30 '15 at 11:41
  • 2
    Which version or build of Windows 10 is it? For some reason, I see the weekday on my clock. What if you pull the taskbar a little higher? – MC10 Jul 30 '15 at 18:08
  • oh, when I pull it 3x small icon high it's there, but 3x small or 2x normal is too big :( – Gizmo Jul 30 '15 at 19:41
up vote 2 down vote accepted

You can use https://github.com/White-Tiger/T-Clock for this, it provides many other options beside custom formats for the clock

  • Yeah I'm using this, I guess this is the only real left option? – Gizmo Mar 15 '17 at 16:53

The weekday will be shown on your horizontal taskbar when you either

  • Have Small Taskbar Icons enabled and the Taskbar is at least 3 rows high or
  • Have Small Taskbar Icons disabled and the Tasbar is at least 2 rows high

If you use the vertical taskbar

  • You need to have it at least 80 pixels wide @ 100% scaling

If you can't pull on your taskbar to resize it right-click it and uncheck Lock all taskbars

You can change the date format of the short date in control panel -> change date, time, or number formats -> additional settings -> date. Set it to something like ddd d-M-yy will give you what you want

  • 1
    I read this trick and it will "damage" other programs that rely on this date, like excel or word. eg insert time now will insert the current day too. – Gizmo Aug 3 '15 at 12:56
  • True. If you use that feature it would be a problem. – askvictor Aug 3 '15 at 21:25

Go to taskbar properties & UN-check "Use small taskbar button". When you use the small taskbar buttons there is not enough room for the date unless you increase the taskbar size.

If you unlock the taskbar and make it a little bigger, it will show the day:

Taller Taskbar

To unlock the taskbar: click Start then the settings icon, go to Taskbar Settings:

enter image description here

And turn "Lock the Taskbar" off:

enter image description here

  • I know it may sound obvious to you, but for some users unlocking taskbar is not really straightforward. Do you mind just adding a quick guide on how would you go about unlocking the taskbar and moving taskbar to the right side? Add this info to your answer. – alljamin Mar 17 '17 at 1:22
  • @alljamin Sure. I added it. I deleted the part about moving the Taskbar to the side because it wasn't related, and it would just confuse the issue. But for reference: Once the Taskbar is unlocked, you can just grab the background of the taskbar with the mouse and drag it to any desktop edge, and it will stick there. – HiredMind Mar 17 '17 at 1:34

Here's a screenshot of me using the d/M/yy ddd setup and turning off small icons.

Screenshot showing control panel settings for date and time, and the taskbar showing the date and day

Image

  • Please add a text answer explaining what's in the image (I can't actually read the text here). – djsmiley2k Mar 17 '17 at 11:51

This fix works, but does screw up usage of the short date format in other programs, such as Outlook, Word, Excel etc. These negative effects, however, are reduced (maybe even eliminated) if you put the "ddd" insert at the END of the short date format. I'm using "M/d/yyyy - ddd" and it doesn't seem to carryover into the other programs in the same way as when I put the "ddd" string at the beginning.

  • Could you include a screenshot of your method in action? – Burgi May 11 '16 at 9:43
  • Go to: Control panel -> Clock and region -> Region
  • in Region 'Format' tab go to 'Additional settings'
  • in the date format box you can change short date. My format is : M/dd-ddd

enter image description here

enter image description here

You have to change the format of the date in the control panel... With the Task bar set to double height> Control Panel>Clock, Language, and Region> Region>Change date, time or number formats.... Select Additional Settings Select Date Tag in short date in "Date Formats" change it to dddd MMM dd, yyyy (Type it in Manually as it is not a selection choice) Select apply then ok this will close the Additional Setting window Select apply then ok this will close the Region Window

Now you should see something like Monday Nov 30, 2015 on the bottom line with the Time above it.

That's about the only way to do this without any additional third party apps

This can change the format across the board in all your apps like Excel/Word and alike when you want to insert the date, it will insert the day as well. If this is not a problem then go ahead and use the steps, if not you will have to put up with no day being displayed... Entirely up to you

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.